summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-20 06:32:54 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-20 07:24:01 +0100
commit4bebf8ebd0b47bdfa42163e164f117fd6c85bccd (patch)
tree7a50fa286cad347c945198e70a33b1fea456fd59
parentdev-python/async-lru: Bump to 2.0.0 (diff)
downloadgentoo-4bebf8eb.tar.gz
gentoo-4bebf8eb.tar.bz2
gentoo-4bebf8eb.zip
dev-python/sphinxcontrib-spelling: Bump to 8.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest1
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-8.0.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index 9306ae49bbd6..c1e796b4b7ba 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-spelling-7.7.0.tar.gz 57444 BLAKE2B 22491369888d632cf158013cb3634e110f3c6a34c59e410a10081f5d1857b85b66f62caf8987058c133f80a8230733fc6e749404207503f0b2441a152fdd5118 SHA512 3599e2d0bcb9bf908b3e6f41184256114e4ab5378543be8bfdd4f55dca249c4feb4fbfda8db4495acfa72fd9ac6c416a0c988f5d30f530eb8deebbcee5833245
+DIST sphinxcontrib-spelling-8.0.0.tar.gz 37610 BLAKE2B 8ae9fb62a5a7d35194884ce075b27b0e54f54c18d55f9573bc53ef7b2f953011655631e37ac3bb7c988df470c8cdf1cb576e4830c61fddc068e50d382d067751 SHA512 0d8c21ea660516238c43fabb505666dfee15abb39f538c40c6b61f91e20c246b16aa170cd444263507dd51913a27fc7719cddb28f30eab26825b565f70dd3ab6
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-8.0.0.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-8.0.0.ebuild
new file mode 100644
index 000000000000..80a2a89145ae
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-8.0.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="
+ https://github.com/sphinx-contrib/spelling/
+ https://pypi.org/project/sphinxcontrib-spelling/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/pyenchant-3.1.1[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-3.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ app-dicts/myspell-en
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires the git repo
+ tests/test_filter.py::test_contributors
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ rm -rf sphinxcontrib || die
+ epytest tests
+}