summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-10-08 19:40:49 -0400
committerMatt Turner <mattst88@gentoo.org>2022-10-08 19:42:09 -0400
commit4bf1106f932e955d649c6c45c871fa3e7dc89909 (patch)
treeec4c438817351c3d3a2a15bcc2ce26ed4a25b153
parentx11-drivers/xf86-input-vmmouse: Call udev_reload (diff)
downloadgentoo-4bf1106f932e955d649c6c45c871fa3e7dc89909.tar.gz
gentoo-4bf1106f932e955d649c6c45c871fa3e7dc89909.tar.bz2
gentoo-4bf1106f932e955d649c6c45c871fa3e7dc89909.zip
x11-drivers/xf86-input-vmmouse: Version bump to 13.2.0
Closes: https://bugs.gentoo.org/864151 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-drivers/xf86-input-vmmouse/Manifest1
-rw-r--r--x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.2.0.ebuild35
-rw-r--r--x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-9999.ebuild6
3 files changed, 39 insertions, 3 deletions
diff --git a/x11-drivers/xf86-input-vmmouse/Manifest b/x11-drivers/xf86-input-vmmouse/Manifest
index 6ce41bce94ea..932540594621 100644
--- a/x11-drivers/xf86-input-vmmouse/Manifest
+++ b/x11-drivers/xf86-input-vmmouse/Manifest
@@ -1 +1,2 @@
DIST xf86-input-vmmouse-13.1.0.tar.bz2 319188 BLAKE2B dddcee47a0d667555ba8a85a4a86c9f922a68ff716f836ac38bb0dbc643011debfbbd2d2054bb8df2f04cc94f2da95cfff7b0ccfb30879e07ca571a9b3aa840a SHA512 38e09c5d7da971eb25ed79fc2daac3b8e1f5e6ec1096424696652c975ea653ed4a49d7779e7735d81a512c12c0a30829d5443ca78a275f3181ebd1740dd2dfd4
+DIST xf86-input-vmmouse-13.2.0.tar.xz 284684 BLAKE2B a63caa3959b47ee4b43dd4e90e7b68706fc39da2d4018965112218c372b4107cbbcebb19fae8fea05a7c95c86a4a793b414ff6cd49e1391fbce04341b7a9eb9c SHA512 26a01347a679db058abdc7cbd9a363bb4fccd1a727dc18e279d15b8a0dce71f67af5ff54df28b908391da8d2fc311d8c1813f26dcded4e9a2668db7b55ca5687
diff --git a/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.2.0.ebuild b/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.2.0.ebuild
new file mode 100644
index 000000000000..401559b5c2d6
--- /dev/null
+++ b/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+XORG_TARBALL_SUFFIX="xz"
+inherit udev xorg-3
+
+DESCRIPTION="VMWare mouse input driver"
+
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="x11-base/xorg-proto"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --with-hal-bin-dir=/punt
+ --with-hal-callouts-dir=/punt
+ --with-hal-fdi-dir=/punt
+ --with-udev-rules-dir=$(get_udevdir)/rules.d
+ )
+ xorg-3_src_configure
+}
+
+src_install() {
+ xorg-3_src_install
+ rm -r "${ED}"/punt || die
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-9999.ebuild b/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-9999.ebuild
index bf63cd4e81b1..c07006dff553 100644
--- a/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-9999.ebuild
+++ b/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
+EAPI=8
+XORG_TARBALL_SUFFIX="xz"
inherit udev xorg-3
DESCRIPTION="VMWare mouse input driver"