summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-29 19:25:51 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-29 23:31:40 +0100
commit4c1ff661e2fc321e840736d1626a9d2f94b35307 (patch)
tree10b403941edacab3bdcd789d4175ec2f29f7577f
parentapp-admin/aws-as-tools: Port to EAPI 6 (diff)
downloadgentoo-4c1ff661.tar.gz
gentoo-4c1ff661.tar.bz2
gentoo-4c1ff661.zip
app-admin/aws-iam-tools: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--app-admin/aws-iam-tools/aws-iam-tools-1.3.0.ebuild36
1 files changed, 18 insertions, 18 deletions
diff --git a/app-admin/aws-iam-tools/aws-iam-tools-1.3.0.ebuild b/app-admin/aws-iam-tools/aws-iam-tools-1.3.0.ebuild
index e70c4d29a090..5714f191ff31 100644
--- a/app-admin/aws-iam-tools/aws-iam-tools-1.3.0.ebuild
+++ b/app-admin/aws-iam-tools/aws-iam-tools-1.3.0.ebuild
@@ -1,50 +1,50 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
DESCRIPTION="The Command Line Interface for the AWS Identity and Access Management Service"
HOMEPAGE="http://aws.amazon.com/developertools/AWS-Identity-and-Access-Management/4143"
SRC_URI="mirror://sabayon/${CATEGORY}/IAMCli-${PV}.zip"
-S="${WORKDIR}/IAMCli-${PV}"
-
LICENSE="Amazon"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+RESTRICT="mirror"
+
DEPEND="app-arch/unzip"
RDEPEND="virtual/jre"
-RESTRICT="mirror"
-src_unpack() {
- unpack ${A}
- cd "${WORKDIR}/IAMCli-${PV}"
+S="${WORKDIR}/IAMCli-${PV}"
+
+src_prepare() {
+ default
find . -name '*.cmd' -delete || die
}
src_install() {
- dodir /opt/${PN}
insinto /opt/${PN}/lib
- doins -r "${S}"/lib/*
+ doins -r lib/.
+
exeinto /opt/${PN}/bin
- doexe "${S}"/bin/*
-
- dodir /etc/env.d
- cat - > "${T}"/99${PN} <<EOF
-AWS_IAM_HOME=/opt/${PN}
-PATH=/opt/${PN}/bin
-ROOTPATH=/opt/${PN}/bin
-EOF
+ doexe bin/*
+
+ cat > "${T}"/99${PN} <<- EOF || die
+ AWS_IAM_HOME=/opt/${PN}
+ PATH=/opt/${PN}/bin
+ ROOTPATH=/opt/${PN}/bin
+ EOF
doenvd "${T}"/99${PN}
- dodoc "LICENSE.txt"
+ dodoc LICENSE.txt
}
pkg_postinst() {
ewarn "Remember to run: env-update && source /etc/profile if you plan"
ewarn "to use these tools in a shell before logging out (or restarting"
ewarn "your login manager)"
+
elog
elog "You need to put the following in your ~/.bashrc replacing the"
elog "values with the full path to your AWS credentials file."