summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-08-25 07:12:27 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-25 21:52:30 +0300
commit4c37294de4ddb2980476127d37bef5eb4d279608 (patch)
treeee05ef5b172b5b903c174f075968911180943e19
parentwww-plugins/chrome-binary-plugins: automated update (106.0.5249.12_alpha) (diff)
downloadgentoo-4c37294d.tar.gz
gentoo-4c37294d.tar.bz2
gentoo-4c37294d.zip
dev-java/jffi: drop 1.3.9
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/27009 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-java/jffi/jffi-1.3.9.ebuild97
1 files changed, 0 insertions, 97 deletions
diff --git a/dev-java/jffi/jffi-1.3.9.ebuild b/dev-java/jffi/jffi-1.3.9.ebuild
deleted file mode 100644
index d74a2940741e..000000000000
--- a/dev-java/jffi/jffi-1.3.9.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/jnr/jffi/archive/jffi-1.3.9.tar.gz --slot 1.3 --keywords "~amd64 ~arm64 ~ppc64 ~x86" --ebuild jffi-1.3.9.ebuild
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source test"
-MAVEN_ID="com.github.jnr:jffi:1.3.9"
-JAVA_TESTING_FRAMEWORKS="junit-4"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="Java Foreign Function Interface"
-HOMEPAGE="https://github.com/jnr/jffi"
-SRC_URI="https://github.com/jnr/${PN}/archive/refs/tags/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="1.3"
-KEYWORDS="amd64 arm64 ~ppc64 x86"
-
-DEPEND=">=virtual/jdk-1.8:*"
-RDEPEND=">=virtual/jre-1.8:*"
-
-PATCHES=( "${FILESDIR}"/jffi-1.3.8-GNUmakefile.patch )
-
-S="${WORKDIR}/${PN}-${P}"
-
-JAVA_SRC_DIR="src/main/java"
-
-# https://github.com/jnr/jffi/blob/b6ad5c066a6346072ea04f8ffa8177204aadcb13/build.xml#L26
-JAVA_TEST_EXTRA_ARGS="-Djffi.library.path=${S}/build/jni -Djffi.boot.library.path=${S}/build/jni"
-JAVA_TEST_GENTOO_CLASSPATH="junit-4"
-JAVA_TEST_SRC_DIR="src/test/java"
-
-src_prepare() {
- default
- cat > src/main/java/com/kenai/jffi/Version.java <<-EOF
- package com.kenai.jffi;
- import java.lang.annotation.Native;
- public final class Version {
- private Version() {}
- @Native
- public static final int MAJOR = $(ver_cut 1);
- @Native
- public static final int MINOR = $(ver_cut 2);
- @Native
- public static final int MICRO = $(ver_cut 3);
- }
- EOF
-}
-
-src_compile() {
- java-pkg-simple_src_compile
-
- # generate headers
- mkdir -p build/jni
- javac -h build/jni -classpath target/classes \
- ${JAVA_SRC_DIR}/com/kenai/jffi/{Foreign,ObjectBuffer,Version}.java \
- || die
-
- #build native library.
- local args=(
- SRC_DIR=jni
- JNI_DIR=jni
- BUILD_DIR=build/jni
- VERSION=$(ver_cut 1-2)
- USE_SYSTEM_LIBFFI=1
- CCACHE=
- -f jni/GNUmakefile
- )
- emake "${args[@]}"
-}
-
-src_test() {
- # build native test library
- emake BUILD_DIR=build -f libtest/GNUmakefile
-
- # https://github.com/jnr/jffi/issues/60
- LC_ALL=C java-pkg-simple_src_test
-}
-
-src_install() {
- default
-
- local libname=".so"
- java-pkg_doso build/jni/lib${PN}-$(ver_cut 1-2)${libname}
-
- # must be after _doso to have JAVA_PKG_LIBDEST set
- cat > boot.properties <<-EOF
- jffi.boot.library.path = ${JAVA_PKG_LIBDEST}
- EOF
- jar -uf ${PN}.jar boot.properties || die
-
- java-pkg-simple_src_install
-}