summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Genasci <fedeliallalinea@gmail.com>2021-01-27 14:11:46 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-01-28 08:41:41 +0200
commit4c50583af170c51dd23102b9d83a3196776289a3 (patch)
treedfbf6b12b1d6a79a45078bf05cd17779f435d6fb
parentdev-util/jenkins-bin: add 2.277 (diff)
downloadgentoo-4c50583a.tar.gz
gentoo-4c50583a.tar.bz2
gentoo-4c50583a.zip
media-gfx/img2pdf: version bump to 0.4.0
Closes: https://bugs.gentoo.org/759184 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Marco Genasci <fedeliallalinea@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/18577 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--media-gfx/img2pdf/Manifest1
-rw-r--r--media-gfx/img2pdf/img2pdf-0.4.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/media-gfx/img2pdf/Manifest b/media-gfx/img2pdf/Manifest
index acbe9c1cbde5..cd9d747f4587 100644
--- a/media-gfx/img2pdf/Manifest
+++ b/media-gfx/img2pdf/Manifest
@@ -1 +1,2 @@
DIST img2pdf-0.3.6.tar.gz 91006 BLAKE2B ad89b42be4613c30383770f336b07773bf13e87061fca61eb7d5e25d6489662fc2bae94d9a6d61d531a77f41b9e94492d0db1f32570f6d471fa9f8cb0816630d SHA512 2a9d31b9de52123941fd650123a483f4dc0757edda304da994353b5f3167bddbb25fa1ed8fededcf859c5d07b65b9c2d5185000949002a68dcae1e7bf0f1547d
+DIST img2pdf-0.4.0.tar.gz 107027 BLAKE2B 0bf13e2d4a5aff68779130bc14100a5c6d1ac4eaca9da28ceb50104550b6e4331f6a2202514bcdac0480c0148794d18e9f2dd46ded68bbaa301a207460f91c85 SHA512 bab9ee6ef5273a686cb10e52bdeb62b6df3c0da99d0f0558677e07dc7ad776c2d62829a2f5e9c5639acfb9fc6e9c5e3a81aed42dc288c2a39d245775f1d4391b
diff --git a/media-gfx/img2pdf/img2pdf-0.4.0.ebuild b/media-gfx/img2pdf/img2pdf-0.4.0.ebuild
new file mode 100644
index 000000000000..eb01f7ad312d
--- /dev/null
+++ b/media-gfx/img2pdf/img2pdf-0.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Losslessly convert raster images to PDF"
+HOMEPAGE="https://gitlab.mister-muffin.de/josch/img2pdf"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gui"
+
+# missing dev-python/pdfrw dependency and
+# require old version of imagemagick
+# waiting new version
+RESTRICT="test"
+
+#BDEPEND="test? (
+# dev-python/numpy[${PYTHON_USEDEP}]
+# dev-python/pdfrw[${PYTHON_USEDEP}]
+# dev-python/pikepdf[${PYTHON_USEDEP}]
+# dev-python/pytest[${PYTHON_USEDEP}]
+# dev-python/scipy[${PYTHON_USEDEP}]
+# <media-gfx/imagemagick-7.0.0[jpeg,jpeg2k,png,q8,q32,tiff]
+#)"
+RDEPEND="dev-python/pikepdf[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ gui? ( $(python_gen_impl_dep tk) )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+ use !gui && sed -i '/gui_scripts/d' setup.py
+}
+
+python_test() {
+ pytest -vv src/img2pdf_test.py || die "Tests fail with ${EPYTHON}"
+}