summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Pettersson <william@ewpettersson.se>2020-06-02 11:05:24 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-06-28 13:40:57 +0300
commit4c564b354f28405db91853878b9f7e71fe441c59 (patch)
treea9de1c0ca20e519f7eb0f483d532a1fff6b1bc48
parentapp-text/xapers: Fix dependencies, enable testing (diff)
downloadgentoo-4c564b35.tar.gz
gentoo-4c564b35.tar.bz2
gentoo-4c564b35.zip
app-text/xapers: Python 3.7/3.8 support
Updates PYTHON_COMPAT for python 3.7 and 3.8 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: William Pettersson <william@ewpettersson.se> Closes: https://github.com/gentoo/gentoo/pull/16051 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-text/xapers/xapers-0.8.2-r1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/app-text/xapers/xapers-0.8.2-r1.ebuild b/app-text/xapers/xapers-0.8.2-r1.ebuild
index 9c57647d3736..808db0ee8572 100644
--- a/app-text/xapers/xapers-0.8.2-r1.ebuild
+++ b/app-text/xapers/xapers-0.8.2-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -11,6 +11,8 @@ inherit distutils-r1
DESCRIPTION="Personal document indexing system"
HOMEPAGE="https://finestructure.net/xapers/"
SRC_URI="https://finestructure.net/xapers/releases/${P}.tar.gz"
+IUSE="test"
+RESTRICT="!test? ( test )"
LICENSE="GPL-3"
SLOT="0"
@@ -24,9 +26,9 @@ RDEPEND="app-text/poppler[utils]
x11-misc/xclip
x11-misc/xdg-utils"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="test? ( ${RDEPEND} )"
-src_tests() {
- ./test.sh
+src_test() {
+ cd test || die
+ ./all || die
}