summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:05:09 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:01 +0100
commit4c60ddd2540a5b853c9ed00333bd67ba68b38615 (patch)
tree23bea16bdae529675cace4488d6b4a34ed5cb65f
parentdev-haskell/typst: new package, add 0.3.2.0 (diff)
downloadgentoo-4c60ddd2540a5b853c9ed00333bd67ba68b38615.tar.gz
gentoo-4c60ddd2540a5b853c9ed00333bd67ba68b38615.tar.bz2
gentoo-4c60ddd2540a5b853c9ed00333bd67ba68b38615.zip
dev-haskell/zip-archive: add 0.4.3
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/zip-archive/Manifest1
-rw-r--r--dev-haskell/zip-archive/metadata.xml1
-rw-r--r--dev-haskell/zip-archive/zip-archive-0.4.3.ebuild37
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/zip-archive/Manifest b/dev-haskell/zip-archive/Manifest
index 12632788186e..651235f2acbc 100644
--- a/dev-haskell/zip-archive/Manifest
+++ b/dev-haskell/zip-archive/Manifest
@@ -1 +1,2 @@
DIST zip-archive-0.4.1.tar.gz 20967 BLAKE2B 0e1276aa9dabf70a36041c5acb6d83a571d067bdb40a8be30b35a2943ec28da92225d8f586101bfa87602186025fd5c61347bf8855216ce2a0101e9ff70a81b4 SHA512 216555bd73a46da5061291c2c071e9c71239bd5ae253ac06ee80ade65bb1871366cc8e4dffbad983c5b6a7f4b0cb2a1439dfa5971db3e183124fa90442a73f0c
+DIST zip-archive-0.4.3.tar.gz 22161 BLAKE2B 8d9a31e1eddb204250b168038809f3ab28af0df6071b67d2f4bec732512516b2aafc7a0e6b11fe886126dbeb5c925d4c3fcfaa649eb65fea4183707b32e02307 SHA512 b98791a22d0dc4b499653bbd88254cff86108bd3a13b59a107cc54e36dc0702c2934eb4b497cbc6239235a45b3486006e52d27faa5af589a124443f8938670ad
diff --git a/dev-haskell/zip-archive/metadata.xml b/dev-haskell/zip-archive/metadata.xml
index e40a68476ea6..c400cbb24af4 100644
--- a/dev-haskell/zip-archive/metadata.xml
+++ b/dev-haskell/zip-archive/metadata.xml
@@ -13,6 +13,7 @@
<flag name="executable">Build the Zip executable.</flag>
</use>
<upstream>
+ <remote-id type="hackage">zip-archive</remote-id>
<remote-id type="github">jgm/zip-archive</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/zip-archive/zip-archive-0.4.3.ebuild b/dev-haskell/zip-archive/zip-archive-0.4.3.ebuild
new file mode 100644
index 000000000000..7bca7c23d822
--- /dev/null
+++ b/dev-haskell/zip-archive/zip-archive-0.4.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Library for creating and modifying zip archives"
+HOMEPAGE="https://github.com/jgm/zip-archive"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="executable"
+
+RDEPEND=">=dev-haskell/digest-0.0.0.1:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( dev-haskell/hunit
+ dev-haskell/temporary )
+"
+# non-haskell depend
+DEPEND="${DEPEND}
+ test? ( app-arch/zip )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable)
+}