summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-02-11 16:25:02 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-02-11 18:13:56 -0500
commit4c6bd8aac93acf27f66a66f0997ccf1e0edd0b1e (patch)
treeb6f1692b2b6ec1e452b72fd6111860206e3f50cc
parentdev-games/cegui: enable py3.10 (diff)
downloadgentoo-4c6bd8aac93acf27f66a66f0997ccf1e0edd0b1e.tar.gz
gentoo-4c6bd8aac93acf27f66a66f0997ccf1e0edd0b1e.tar.bz2
gentoo-4c6bd8aac93acf27f66a66f0997ccf1e0edd0b1e.zip
games-util/nml: add 0.6.1, modernize and enable py3.10
Its opengfx revdep was broken with 0.5.3+py3.10 but seems fixed in 0.6.1 (not that I'm very familiar with openttd packages and how in-sync they need to be, hopefully this is fine). Closes: https://bugs.gentoo.org/808123 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-util/nml/Manifest1
-rw-r--r--games-util/nml/nml-0.6.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/games-util/nml/Manifest b/games-util/nml/Manifest
index ceca62690530..f38ce0f282c9 100644
--- a/games-util/nml/Manifest
+++ b/games-util/nml/Manifest
@@ -1 +1,2 @@
DIST nml-0.5.3.tar.gz 532842 BLAKE2B dbd775ca8b066fd60cd8fa1a377c95d337a61ba353fa527bb45f929d13b89a41c65156cff22f8ded6526444fdc74c82987da045e6355b411a30c0593a3a39edb SHA512 518be737273af6bfff23f223d07328312c4b7e070a334d4b0ecffc303aab8257ad8b26ff3b74e992db263d446fedc3e0080573b6670f0061ca78bb933c959c6a
+DIST nml-0.6.1.tar.gz 543048 BLAKE2B c602ad37cd6a321d8e5d0a1cbac22844b2cd2f182e768972db4eb171215a4fe67f9ffe632d50c85c55d00e437dff93bec17d65a3dff2e2912bc474ce9fcc4b6c SHA512 41b1f1c256543ef42067ef3bb81dbb10771498f3dc06e6ce1b328723710380b2a6dad52b2258716b6caab3e4f17d22d57992c76e0800440b9daff5811304e016
diff --git a/games-util/nml/nml-0.6.1.ebuild b/games-util/nml/nml-0.6.1.ebuild
new file mode 100644
index 000000000000..a378873b7b05
--- /dev/null
+++ b/games-util/nml/nml-0.6.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Compiler of NML files into GRF/NFO files"
+HOMEPAGE="https://github.com/OpenTTD/nml/"
+SRC_URI="https://github.com/OpenTTD/nml/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pillow[${PYTHON_USEDEP},zlib]
+ dev-python/ply[${PYTHON_USEDEP}]')"
+
+src_install() {
+ local DOCS=( README.md docs/changelog.txt )
+ distutils-r1_src_install
+
+ doman docs/nmlc.1
+}