summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-02 07:52:50 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-02 08:37:24 +0100
commit4c6fb553ea5d0d266e602fb6620ccb8867ad808d (patch)
treea8be2f8c58d0141066bec170962581e5f6d5951d
parentdev-python/Faker: Remove old (diff)
downloadgentoo-4c6fb553.tar.gz
gentoo-4c6fb553.tar.bz2
gentoo-4c6fb553.zip
dev-python/Faker: Bump to 15.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/Faker/Faker-15.1.3.ebuild35
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-15.1.3.ebuild b/dev-python/Faker/Faker-15.1.3.ebuild
new file mode 100644
index 000000000000..5db43c1f3c0f
--- /dev/null
+++ b/dev-python/Faker/Faker-15.1.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index 9fcde92d8cb6..df8dd125e82d 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1 +1,2 @@
DIST Faker-15.1.1.tar.gz 1600615 BLAKE2B 42a9baf41b6c4d301ff5ccfe4dcab354eb4caeb714ad5284ac094b157d855e60cf281062f4538d3ba5fd11521cf3fae73cc85b0d286432736f392b37816466fe SHA512 2af0f6c102f169238f2a08c44211c11318dce51356642453349de7a97b436baa378d8a46500adab82df508a2ba7686d80669902d039f08078741e32fd19f9774
+DIST Faker-15.1.3.tar.gz 1595238 BLAKE2B 98ed2da677ae7b48c1def8476cd0c6b282ce3298a7538ffda0a4d67aadef33456317003dba1b18386868a52ca9565639c2bf1ffde469ca59034606cfe78bf008 SHA512 a1f053b14274f5161c8e024879f4a1e344cfc17cb158ff6e284120d40b3f3237d19707a761999035de1fe10a87d29b3aeff1cfd9ec2199ade4fb60bac2a67433