summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-10-31 14:31:41 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-10-31 14:31:41 +0100
commit4c9f72cc9d5162ff1ea736e9ac371b22e5d93084 (patch)
tree8a129b27314decffc1fb977e350a5553f60a0586
parentwww-servers/nginx: drop vulnerable (diff)
downloadgentoo-4c9f72cc.tar.gz
gentoo-4c9f72cc.tar.bz2
gentoo-4c9f72cc.zip
net-misc/igmpproxy: add 0.4
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--net-misc/igmpproxy/Manifest1
-rw-r--r--net-misc/igmpproxy/igmpproxy-0.4.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/igmpproxy/Manifest b/net-misc/igmpproxy/Manifest
index b95a32c6d533..993628fbced8 100644
--- a/net-misc/igmpproxy/Manifest
+++ b/net-misc/igmpproxy/Manifest
@@ -1 +1,2 @@
DIST igmpproxy-0.3.tar.gz 168403 BLAKE2B 4dd07936074fbd9b3c869851f5b592f1eec33109be78ee5a05b3658c26afb67c30379f7cc66dfa20af276aae0a1c21dbf5c9fd337c853d623b08126324b06561 SHA512 0b1deca544317e2f0b1ff550e5921e8d6f64565f7cd72b6210fc7d3d7c3a301875088687a31ca5a29d310b2931695bd7a77e41dc5685ab7175ea1d41fe9246af
+DIST igmpproxy-0.4.tar.gz 170700 BLAKE2B 233af2fe35a0d661211d205fec89cce0a7dc91fe1530e940703e6d56eeb69f4490ca16d18787dbbaf7c0087dc2ebcb61d212778993af6fbb8acc7ba33429f7e0 SHA512 ad5d8f0794cf74e42f6f99a57815402904ef7f03b76a901885c16aa0d148e552ce001832e82e4cc4ac33e2d4fd6059c51352363f13f192bca48ea9bca12c640c
diff --git a/net-misc/igmpproxy/igmpproxy-0.4.ebuild b/net-misc/igmpproxy/igmpproxy-0.4.ebuild
new file mode 100644
index 000000000000..3683a01cbe83
--- /dev/null
+++ b/net-misc/igmpproxy/igmpproxy-0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info systemd
+
+DESCRIPTION="A multicast routing daemon which uses IGMP forwarding"
+HOMEPAGE="https://github.com/pali/igmpproxy"
+SRC_URI="https://github.com/pali/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+
+CONFIG_CHECK="~IP_MULTICAST ~IP_MROUTE"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/igmpproxy.initd-r1 igmpproxy
+ systemd_dounit "${FILESDIR}"/"${PN}".service
+
+ newconfd "${FILESDIR}"/igmpproxy.confd igmpproxy
+}