summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2017-01-08 14:27:28 +0900
committerBenda Xu <heroxbd@gentoo.org>2017-01-09 23:00:27 +0900
commit4ca62c0895c2c282af330706fb8b172a57a8618c (patch)
treea55c7837327419b642e917fe4c8612defe46da46
parenttoolchain.eclass: Prepend/strip EPREFIX. (diff)
downloadgentoo-4ca62c0895c2c282af330706fb8b172a57a8618c.tar.gz
gentoo-4ca62c0895c2c282af330706fb8b172a57a8618c.tar.bz2
gentoo-4ca62c0895c2c282af330706fb8b172a57a8618c.zip
toolchain.eclass: Quote variables containing EPREFIX.
Directory prefixify part 4. LIBPATH, etc. now have EPREFIX prepended. The latter need to be quoted. Bug: 531610
-rw-r--r--eclass/toolchain.eclass22
1 files changed, 11 insertions, 11 deletions
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index f54316ca0963..941e37b40cf9 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -983,10 +983,10 @@ toolchain_src_configure() {
elif built_with_use --hidden --missing false ${CATEGORY}/${needed_libc} crosscompile_opts_headers-only ; then
confgcc+=(
"${confgcc_no_libc[@]}"
- --with-sysroot=${PREFIX}/${CTARGET}
+ --with-sysroot="${PREFIX}"/${CTARGET}
)
else
- confgcc+=( --with-sysroot=${PREFIX}/${CTARGET} )
+ confgcc+=( --with-sysroot="${PREFIX}"/${CTARGET} )
fi
fi
@@ -1812,11 +1812,11 @@ toolchain_src_install() {
# Use gid of 0 because some stupid ports don't have
# the group 'root' set to gid 0. Send to /dev/null
# for people who are testing as non-root.
- chown -R root:0 "${D}"${LIBPATH} 2>/dev/null
+ chown -R root:0 "${D}${LIBPATH}" 2>/dev/null
# Move pretty-printers to gdb datadir to shut ldconfig up
local py gdbdir=/usr/share/gdb/auto-load${LIBPATH/\/lib\//\/$(get_libdir)\/}
- pushd "${D}"${LIBPATH} >/dev/null
+ pushd "${D}${LIBPATH}" >/dev/null
for py in $(find . -name '*-gdb.py') ; do
local multidir=${py%/*}
insinto "${gdbdir}/${multidir}"
@@ -1862,16 +1862,16 @@ gcc_movelibs() {
local OS_MULTIDIR=$($(XGCC) ${multiarg} --print-multi-os-directory)
local MULTIDIR=$($(XGCC) ${multiarg} --print-multi-directory)
- local TODIR=${D}${LIBPATH}/${MULTIDIR}
+ local TODIR="${D}${LIBPATH}"/${MULTIDIR}
local FROMDIR=
[[ -d ${TODIR} ]] || mkdir -p ${TODIR}
for FROMDIR in \
- ${LIBPATH}/${OS_MULTIDIR} \
- ${LIBPATH}/../${MULTIDIR} \
- ${PREFIX}/lib/${OS_MULTIDIR} \
- ${PREFIX}/${CTARGET}/lib/${OS_MULTIDIR}
+ "${LIBPATH}"/${OS_MULTIDIR} \
+ "${LIBPATH}"/../${MULTIDIR} \
+ "${PREFIX}"/lib/${OS_MULTIDIR} \
+ "${PREFIX}"/${CTARGET}/lib/${OS_MULTIDIR}
do
removedirs="${removedirs} ${FROMDIR}"
FROMDIR=${D}${FROMDIR}
@@ -2034,12 +2034,12 @@ gcc_slot_java() {
# Move random gcj files to compiler-specific directories
for x in libgcj.spec logging.properties ; do
x="${D}${PREFIX}/lib/${x}"
- [[ -f ${x} ]] && mv -f "${x}" "${D}"${LIBPATH}/
+ [[ -f ${x} ]] && mv -f "${x}" "${D}${LIBPATH}"/
done
# Rename jar because it could clash with Kaffe's jar if this gcc is
# primary compiler (aka don't have the -<version> extension)
- cd "${D}"${BINPATH}
+ cd "${D}${BINPATH}"
[[ -f jar ]] && mv -f jar gcj-jar
}