summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-28 05:29:44 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-28 06:06:34 +0100
commit4cc0e9e25c865df333888626c8ca2d39e782dc7e (patch)
tree2c7f9319b1a9b55b7be06a0c4512d5f848c9d994
parentdev-python/boto3: Bump to 1.26.80 (diff)
downloadgentoo-4cc0e9e2.tar.gz
gentoo-4cc0e9e2.tar.bz2
gentoo-4cc0e9e2.zip
app-admin/awscli: Bump to 1.27.80
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.80.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 64094936f5ff..61ab0c19c5b3 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,2 +1,3 @@
DIST aws-cli-1.27.74.gh.tar.gz 2368706 BLAKE2B 3eb9d8c21b9ddfd3a3e4bb53172a46ad69ca71033785bd29fd8b0b0f694c2ed62a4cad998ccd13b07949b86a89f2ca238a63a4553e591ba9066832f51ed87759 SHA512 cf61a3f1dd643bb7d0f81f047c1eeae78a7793532bffa612045273c46ae970b2763156a7679b6e16e65c2f886dec68e54db0169580bb3c37cc08420f874e704c
DIST aws-cli-1.27.79.gh.tar.gz 2376690 BLAKE2B 8e55d3607b805ebc5673c682731483f0fd6eb77a6cc972d58ce3219c33f9f2054529df6ab46fc85b39849871580cea03c4d7f490c4386cd5ce9d222ecb3c8eda SHA512 fd8b880b6358c50ed189fac538d91ef88d762b8c382da1b57bb086a316f7ee96fa33206a53f3eae2df98df175929c819b855c7ff5b7e5f84c73ecff88f297c79
+DIST aws-cli-1.27.80.gh.tar.gz 2377306 BLAKE2B 3a0e6c66bb9c373456bb05537f20ad339c0987290557c30dbd2e2a8ea127b0f8bfc7028930db712fcbe7461c7bc87dac123c1847da93b675403822f6c02b1d3f SHA512 b94aab2588e8bc0ad007e0392c6eed0642683246b1803007332563495a69deb5da924eda48944e37b674c714cf2e5a45aeddbbedb5d12d51ad8c9c8e76c18ebc
diff --git a/app-admin/awscli/awscli-1.27.80.ebuild b/app-admin/awscli/awscli-1.27.80.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.80.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}