summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-03-05 11:48:41 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2017-03-05 12:02:21 -0800
commit4cc9827ebd8e7c50e8ca0cd2449e4894a7acb88f (patch)
tree2a78fb8fd07e5793ca81598d82014674cdad0b57
parentmedia-plugins/vdr-markad: Remove required ffmpeg flag x264, as only decoding ... (diff)
downloadgentoo-4cc9827ebd8e7c50e8ca0cd2449e4894a7acb88f.tar.gz
gentoo-4cc9827ebd8e7c50e8ca0cd2449e4894a7acb88f.tar.bz2
gentoo-4cc9827ebd8e7c50e8ca0cd2449e4894a7acb88f.zip
net-dialup/minicom: Force lockdir to /var/lock
Upstream uses automagic detection of the first existing directory of: /etc/locks /var/lock /usr/spool/locks /var/spool/locks /var/spool/lock /usr/spool/uucp /var/spool/uucp /var/run While many of these will exist in a live system, that was not a safe assumption during a chrooted package build, such as stage building. The init system is responsible for creating /var/lock, so force the lockdir to that. Package-Manager: portage-2.3.3 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-rw-r--r--net-dialup/minicom/files/minicom-2.7-lockdir.patch14
-rw-r--r--net-dialup/minicom/minicom-2.7-r1.ebuild59
2 files changed, 73 insertions, 0 deletions
diff --git a/net-dialup/minicom/files/minicom-2.7-lockdir.patch b/net-dialup/minicom/files/minicom-2.7-lockdir.patch
new file mode 100644
index 000000000000..acbdcbe902ba
--- /dev/null
+++ b/net-dialup/minicom/files/minicom-2.7-lockdir.patch
@@ -0,0 +1,14 @@
+--- minicom-2.7.orig/configure.in 2013-12-31 07:14:09.000000000 -0800
++++ minicom-2.7/configure.in 2017-03-05 11:25:01.379020326 -0800
+@@ -217,7 +217,10 @@
+
+ if test "x$UUCPLOCK" != x
+ then
+- if test -d $UUCPLOCK
++ dnl If a lock directory was manually specified, do not test it actually
++ dnl exists, as that might not be true during a chroot build, and the
++ dnl packager is responsible for making sure it exists at runtime.
++ if true
+ then
+ AC_MSG_RESULT($UUCPLOCK)
+ AC_DEFINE_UNQUOTED(UUCPLOCK, "$UUCPLOCK", [Lock directory])
diff --git a/net-dialup/minicom/minicom-2.7-r1.ebuild b/net-dialup/minicom/minicom-2.7-r1.ebuild
new file mode 100644
index 000000000000..fece4e19b3ed
--- /dev/null
+++ b/net-dialup/minicom/minicom-2.7-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils autotools
+
+STUPID_NUM="3977"
+DESCRIPTION="Serial Communication Program"
+HOMEPAGE="http://alioth.debian.org/projects/minicom"
+SRC_URI="https://alioth.debian.org/frs/download.php/file/${STUPID_NUM}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="nls"
+
+COMMON_DEPEND="sys-libs/ncurses:="
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${COMMON_DEPEND}
+ net-dialup/lrzsz"
+
+DOCS="AUTHORS ChangeLog NEWS README doc/minicom.FAQ"
+
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" cs da de es fi fr hu id ja nb pl pt_BR ro ru rw sv vi zh_TW"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3-gentoo-runscript.patch
+ "${FILESDIR}"/${PN}-2.7-lockdir.patch
+)
+
+src_prepare() {
+ default
+ mv "${S}"/configure.{in,ac}
+ eautoreconf
+}
+
+src_configure() {
+ # Lockdir must exist if not manually specified.
+ # /var/lock is created by openrc.
+ LOCKDIR=/var/lock
+ econf \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --enable-lock-dir="${LOCKDIR}" \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+ insinto /etc/minicom
+ doins "${FILESDIR}"/minirc.dfl
+}
+
+pkg_preinst() {
+ [[ -s ${EROOT}/etc/minicom/minirc.dfl ]] && rm -f "${ED}"/etc/minicom/minirc.dfl
+}