summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2019-01-12 13:46:11 +0000
committerCraig Andrews <candrews@gentoo.org>2019-01-12 22:17:18 -0500
commit4ccfcada730b9bb00f67968b7cf5d016800b6a6d (patch)
tree218583c67ecced86e3551e34b286941bb5a70765
parentapp-emulation/libvirt: Rebase patches for 5.0.0 release (diff)
downloadgentoo-4ccfcada730b9bb00f67968b7cf5d016800b6a6d.tar.gz
gentoo-4ccfcada730b9bb00f67968b7cf5d016800b6a6d.tar.bz2
gentoo-4ccfcada730b9bb00f67968b7cf5d016800b6a6d.zip
dev-util/bitcoin-tx-0.17.1: Fix build without libevent
Fixes: https://bugs.gentoo.org/675256 Signed-off-by: Luke Dashjr <luke-jr+git@utopios.org> Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--dev-util/bitcoin-tx/bitcoin-tx-0.17.1.ebuild2
-rw-r--r--dev-util/bitcoin-tx/files/0.17.1-no-libevent.patch20
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/bitcoin-tx/bitcoin-tx-0.17.1.ebuild b/dev-util/bitcoin-tx/bitcoin-tx-0.17.1.ebuild
index a431bbafab73..4346aa025916 100644
--- a/dev-util/bitcoin-tx/bitcoin-tx-0.17.1.ebuild
+++ b/dev-util/bitcoin-tx/bitcoin-tx-0.17.1.ebuild
@@ -63,6 +63,8 @@ src_prepare() {
mkdir -p src/obj || die
echo "#define BUILD_SUFFIX gentoo${PVR#${PV}}" >src/obj/build.h || die
+ eapply "${FILESDIR}/${PV}-no-libevent.patch"
+
eautoreconf
rm -r src/leveldb src/secp256k1 || die
}
diff --git a/dev-util/bitcoin-tx/files/0.17.1-no-libevent.patch b/dev-util/bitcoin-tx/files/0.17.1-no-libevent.patch
new file mode 100644
index 000000000000..b0e4a9548755
--- /dev/null
+++ b/dev-util/bitcoin-tx/files/0.17.1-no-libevent.patch
@@ -0,0 +1,20 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1101,7 +1101,7 @@ if test x$use_pkgconfig = xyes; then
+ if test x$use_qr != xno; then
+ BITCOIN_QT_CHECK([PKG_CHECK_MODULES([QR], [libqrencode], [have_qrencode=yes], [have_qrencode=no])])
+ fi
+- if test x$build_bitcoin_cli$build_bitcoin_tx$build_bitcoind$bitcoin_enable_qt$use_tests != xnonononono; then
++ if test x$build_bitcoin_cli$build_bitcoind$bitcoin_enable_qt$use_tests != xnononono; then
+ PKG_CHECK_MODULES([EVENT], [libevent],, [AC_MSG_ERROR(libevent not found.)])
+ if test x$TARGET_OS != xwindows; then
+ PKG_CHECK_MODULES([EVENT_PTHREADS], [libevent_pthreads],, [AC_MSG_ERROR(libevent_pthreads not found.)])
+@@ -1126,7 +1126,7 @@ else
+ AC_CHECK_HEADER([openssl/ssl.h],, AC_MSG_ERROR(libssl headers missing),)
+ AC_CHECK_LIB([ssl], [main],SSL_LIBS=-lssl, AC_MSG_ERROR(libssl missing))
+
+- if test x$build_bitcoin_cli$build_bitcoin_tx$build_bitcoind$bitcoin_enable_qt$use_tests != xnonononono; then
++ if test x$build_bitcoin_cli$build_bitcoind$bitcoin_enable_qt$use_tests != xnononono; then
+ AC_CHECK_HEADER([event2/event.h],, AC_MSG_ERROR(libevent headers missing),)
+ AC_CHECK_LIB([event],[main],EVENT_LIBS=-levent,AC_MSG_ERROR(libevent missing))
+ if test x$TARGET_OS != xwindows; then