summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-09-30 09:28:51 +0800
committerYixun Lan <dlan@gentoo.org>2021-09-30 09:28:51 +0800
commit4ce0decd3ac5caa6cf53e46c7bb55b96d470d40d (patch)
tree3cb71049e3a19249c153ec7f16b006f9cdcff589
parentdev-vcs/git-pw: fix tests error (diff)
downloadgentoo-4ce0decd.tar.gz
gentoo-4ce0decd.tar.bz2
gentoo-4ce0decd.zip
dev-vcs/git-pw: drop old
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--dev-vcs/git-pw/Manifest1
-rw-r--r--dev-vcs/git-pw/git-pw-2.0.0.ebuild44
2 files changed, 0 insertions, 45 deletions
diff --git a/dev-vcs/git-pw/Manifest b/dev-vcs/git-pw/Manifest
index 20159044bf9c..10daf2fac340 100644
--- a/dev-vcs/git-pw/Manifest
+++ b/dev-vcs/git-pw/Manifest
@@ -1,2 +1 @@
-DIST git-pw-2.0.0.tar.gz 32151 BLAKE2B f8ef04b31cb4457ac9bae333bae65deb7d17469cd25a3724a27201dab0c05f98151a5ec1066cb9d2de81d82360f4e46eaa59ebd08904dfa0d16106f589e17e4c SHA512 83ac4d56091bfe9b03733939fb3e4feab22ce4455eebe8508bc730705b69054a2f060cfb8a1ea469476d9519809a89116ff56210efe4cd76e50df5a5d40886fc
DIST git-pw-2.1.1.tar.gz 32489 BLAKE2B 516eb3b81c3798a455b7122a3b0ad9bf0d9722eb6f301ea58ed766cca94137f4da4eaf34a40ec7c5e108368aa6099f9401aba6d71d463913cd2b7fd9dc7aef09 SHA512 3cbf0670bf811d6b6ef0d4c5c7ad4321380d442c62fd15869758b26b4fc375c2d4bd2bdbf693a41d0cbe862bdef15fc02d04124a089f7786bd1b2e56f818e0c2
diff --git a/dev-vcs/git-pw/git-pw-2.0.0.ebuild b/dev-vcs/git-pw/git-pw-2.0.0.ebuild
deleted file mode 100644
index a27a91f9a2c5..000000000000
--- a/dev-vcs/git-pw/git-pw-2.0.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit distutils-r1
-if [[ "${PV}" == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/getpatchwork/git-pw.git"
-else
- SRC_URI="https://github.com/getpatchwork/git-pw/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="A tool for integrating Git with Patchwork"
-HOMEPAGE="https://github.com/getpatchwork/git-pw"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- >=dev-python/arrow-0.10[${PYTHON_USEDEP}]
- <dev-python/click-8.0[${PYTHON_USEDEP}]
- dev-python/pbr[${PYTHON_USEDEP}]
- <dev-python/requests-3.0[${PYTHON_USEDEP}]
- >=dev-python/tabulate-0.8[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/pbr[${PYTHON_USEDEP}]
- test? (
- >=dev-python/mock-3.0.0[${PYTHON_USEDEP}]
- <dev-python/pytest-6.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-cov-2.5[${PYTHON_USEDEP}]
- )
-"
-
-src_compile() {
- export PBR_VERSION=${PV}
- distutils-r1_src_compile
-}
-distutils_enable_tests pytest