summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-20 03:15:04 +0100
committerSam James <sam@gentoo.org>2021-09-20 03:15:04 +0100
commit4ceef02360f49a8bad06d35351088403d9aea40d (patch)
tree93601e6d7559871fcede702c1f58a60d2261e8e6
parentdev-lang/python: stable 3.6.14_p1 for hppa, bug #811225 (diff)
downloadgentoo-4ceef023.tar.gz
gentoo-4ceef023.tar.bz2
gentoo-4ceef023.zip
sys-apps/moreutils: add 0.66
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/moreutils/Manifest1
-rw-r--r--sys-apps/moreutils/moreutils-0.66.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/sys-apps/moreutils/Manifest b/sys-apps/moreutils/Manifest
index 3a4d6185ba9a..74618f04f56e 100644
--- a/sys-apps/moreutils/Manifest
+++ b/sys-apps/moreutils/Manifest
@@ -1 +1,2 @@
DIST moreutils-0.65.tar.gz 93180 BLAKE2B 2105cc281b9f4c9598bb0cdd5a4b9b8042e77eb14de323ba889c182c956b00d7b8a899c4112542e0a3d513fd961ee0ed6c82dd2dbefffe50e1d4fd326919ef4f SHA512 dcad2a3b6d9621da6d2f860f39acb04c80d42cc2123e12a6ec84524f6a1fc7f5ae4bd5d00e698fe14d4c5e7d491d790970ce4370c9abd1f63318d1c512f596b9
+DIST moreutils-0.66.tar.gz 93387 BLAKE2B 783ed558f0f77c2b384a1aa8852243242ce24e44e40b58f92e2179308df9cc3a27142820a7743c25ba4529a4b7ea7ae20c1fc02b86324638a7d13ad7536c6b21 SHA512 6c5f8b677d9912cf4e7aabf442361c89d23767f2a5df0a2c29ab72314e1ed3767a0a7a7abaa5044cf73ef877184d16e1d58e340780971e9e1299857756aca6a3
diff --git a/sys-apps/moreutils/moreutils-0.66.ebuild b/sys-apps/moreutils/moreutils-0.66.ebuild
new file mode 100644
index 000000000000..2a5608311949
--- /dev/null
+++ b/sys-apps/moreutils/moreutils-0.66.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A collection of tools that nobody thought to write when Unix was young"
+HOMEPAGE="https://joeyh.name/code/moreutils/ https://git.joeyh.name/index.cgi/moreutils.git/"
+# Not available at time of release
+#SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.xz"
+SRC_URI="https://git.joeyh.name/index.cgi/moreutils.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~x86-linux ~x64-macos"
+IUSE="+doc +perl"
+
+RDEPEND="
+ app-admin/eselect
+ perl? (
+ dev-lang/perl
+ dev-perl/IPC-Run
+ dev-perl/Time-Duration
+ dev-perl/TimeDate
+ )
+"
+DEPEND="
+ doc? (
+ >=app-text/docbook2X-0.8.8-r2
+ app-text/docbook-xml-dtd:4.4
+ dev-lang/perl
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.64-respect-env.patch"
+)
+
+src_prepare() {
+ # don't build manpages
+ if ! use doc ; then
+ sed -i -e '/^all:/s/$(MANS)//' -e '/man1/d' Makefile || die
+ fi
+
+ # don't install perl scripts
+ if ! use perl ; then
+ sed -i -e '/PERLSCRIPTS/d' Makefile || die
+ fi
+
+ default
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS}" DOCBOOKXSL="${EPREFIX}"/usr/share/sgml/docbook/xsl-stylesheets PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" INSTALL_BIN=install install
+
+ # sys-process is more advanced than parallel from moreutils, rename it
+ if use doc; then
+ mv "${ED}"/usr/share/man/man1/{,${PN}_}parallel.1 || die
+ fi
+
+ mv "${ED}"/usr/bin/{,${PN}_}parallel || die
+}
+
+pkg_postinst() {
+ # Try to make sure $EDITOR is valid for vipe (bug #604630)
+ eselect editor update
+}