summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-01-21 20:39:46 -0500
committerVirgil Dupras <vdupras@gentoo.org>2019-01-21 20:39:46 -0500
commit4d1cea15bd7d05fe6f6b280bf7d5eee320ac8548 (patch)
tree46401dc6b1af1f3067550c67ea448430237b2e52
parentmedia-sound/pulseeffects: 4.4.7 bump (diff)
downloadgentoo-4d1cea15.tar.gz
gentoo-4d1cea15.tar.bz2
gentoo-4d1cea15.zip
dev-python/pytest: bump to 4.1.1
Removed "-vv" from "pytest" invocation because it made 3 tests fail. Removed test exclusions that seem to have solved themselves (they don't fail anymore). Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-python/pytest/Manifest2
-rw-r--r--dev-python/pytest/pytest-4.1.1.ebuild (renamed from dev-python/pytest/pytest-4.1.0.ebuild)12
2 files changed, 6 insertions, 8 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index 281c5eb28839..0c1c0ba15913 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -1,4 +1,4 @@
DIST pytest-3.10.1.tar.gz 892420 BLAKE2B 38849ae69bf4380bc1a99aa105cac04be078da4460373dfc16fa555238b2830fa2f5ae6c19de8aa2af9ac18d87c5d2705d62f7b2e67e4a62d843f6a28bbd76fd SHA512 30ff79c0fdcbeef68e1191ff400a20428e391717f06957f554b694b94baaaa565dca01346fe989c3e443c4402f3b2bdbd5564f6303a4447f933fb54cba45628f
DIST pytest-3.2.2.tar.gz 786396 BLAKE2B e669da930890e902b0323ec3a6685080ddd889e74655f7b4cb08ec421651f987597021a31471aab5a32d637b99620ce7792cbdf8f85561db3bb10ff06a446ba1 SHA512 6df3a50e7d1efeaf7a283920b16d1daf800798f422bc851b0aacd2bbd5cb0a88c95f9057fae49943b9dfe6527ed552cdf8d983b944ab91d0af252ee4f6eb82db
DIST pytest-3.4.2.tar.gz 812719 BLAKE2B 96623d6cdea4bd79778175c18c949938505f1862010f700f9a8cb85f445910381af391a5b69e664fbbfc254bf46502c798c72026772070236a0a3bca7aeeb3d6 SHA512 787065ab76d4482799bb2da9f024c9c383e68cc1cc01f3b80f6ed9444ca6383d20953615696ed4dd01668777b094cf5002b23c4ce51828879dcf8ebf2170c71b
-DIST pytest-4.1.0.tar.gz 902235 BLAKE2B 6289d13f6d81130fe4a1ea25dbe93c76206cd61c11e3c18bb5febd92539f37f45144565680a6df097667a5e940e545e7973193abd214bff7b9287d9b42b00e56 SHA512 30cbefa066728b72063b21190df74b7cbf56d045e87307915af45e3ff5cdbb76c79dd0c2428425c2db9f8f0ba99a116d787526dc806801787b89a7862dd9e56e
+DIST pytest-4.1.1.tar.gz 903912 BLAKE2B 6466f8620ddf509ad17c9fddd8d9afd8cd53b67673bf12c603a563daa30decd6ca067ec829bece49505650536c02854493ed27d5dd350f2bd5cbd4c71c85721a SHA512 e93b742b61fdba7518d833bdc312282347853abb1fe76920f14e791ede2af57513b521b967303483dfc2e308ec83c9c9e1f8d81489ee5610808e3b33b42b8452
diff --git a/dev-python/pytest/pytest-4.1.0.ebuild b/dev-python/pytest/pytest-4.1.1.ebuild
index 35286e06a77f..35de82a23ee4 100644
--- a/dev-python/pytest/pytest-4.1.0.ebuild
+++ b/dev-python/pytest/pytest-4.1.1.ebuild
@@ -51,15 +51,13 @@ python_prepare_all() {
# https://bugs.gentoo.org/598442
rm testing/test_pdb.py || die
- # those tests appear to hang with python3.5+; TODO: investigate why
- sed -i -e 's:test_runtest_location_shown_before_test_starts:_&:' \
- testing/test_terminal.py || die
- sed -i -e 's:test_trial_pdb:_&:' testing/test_unittest.py || die
-
distutils-r1_python_prepare_all
}
python_test() {
- "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py --lsof -rfsxX \
- -vv testing || die "tests failed with ${EPYTHON}"
+ # In v4.1.1, pytest started being picky about its own verbosity options.
+ # running pytest on itself with -vv made 3 tests fail. This is why we don't
+ # have it below.
+ "${EPYTHON}" "${BUILD_DIR}"/lib/pytest.py --lsof -rfsxX \
+ || die "tests failed with ${EPYTHON}"
}