summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <michal.privoznik@gmail.com>2024-04-13 20:12:34 +0200
committerSam James <sam@gentoo.org>2024-04-13 19:48:00 +0100
commit4d2886ec579ed3a15369ac939130bffaf6c48ff9 (patch)
tree93a380e31bb7c47bdd31467599da186247361f21
parentdev-python/libvirt-python: Add 10.2.0 (diff)
downloadgentoo-4d2886ec.tar.gz
gentoo-4d2886ec.tar.bz2
gentoo-4d2886ec.zip
dev-perl/Sys-Virt: Add 10.2.0
Signed-off-by: Michal Privoznik <michal.privoznik@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36241 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-perl/Sys-Virt/Manifest1
-rw-r--r--dev-perl/Sys-Virt/Sys-Virt-10.2.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Sys-Virt/Manifest b/dev-perl/Sys-Virt/Manifest
index a2e92c1d359a..0155453310ec 100644
--- a/dev-perl/Sys-Virt/Manifest
+++ b/dev-perl/Sys-Virt/Manifest
@@ -1,2 +1,3 @@
DIST Sys-Virt-v10.1.0.tar.gz 175345 BLAKE2B 19f5620f546b1ea0f6dda0126b56735102f7513b9c41b86e1892f846a84fdfac0f1296a4d1238c7f1cc5c1e5704d5fb8f8dc81cc3961ca59acca5403fa580701 SHA512 6b20573e953bd99e547da683cfc587dd132f8b7921ae76289aad9891179b7d068c96a0c67f90b6daa7c5bf0156de02b3a85f7ec538ee47ca4f81547f03256003
+DIST Sys-Virt-v10.2.0.tar.gz 175575 BLAKE2B 2950f991be8ae130788b1b03c1f898fb778b67765aa93732540a1fe5057a66e7a4efb7c7792327b81816281d7ba910466b24a50ec36165e554f1cb481693fba4 SHA512 c362e37511aff879b08a67b6337cee6d20c197fea2bb7f6ce023eafa642f53029744d704250533772fd48448ff39ea49027b83563cd9821dcd22d3621b2372ef
DIST Sys-Virt-v9.7.0.tar.gz 174737 BLAKE2B 676be20e39102f92b9b1d3cc703479c67f43d7007f01f9cfb725d13002ba0abdb3123ac756ace666ffd3c67224943281ad79b840c50afbfd4e8f7f9c5ca4be27 SHA512 211cc36536ec8538e096d36bca568b0362a2c84fe78322acb34a473a91128f46251503db14e38b63cd865a2f16b5c021e6e75ec1832368ae26480bb7e32180d4
diff --git a/dev-perl/Sys-Virt/Sys-Virt-10.2.0.ebuild b/dev-perl/Sys-Virt/Sys-Virt-10.2.0.ebuild
new file mode 100644
index 000000000000..16cad8c07a60
--- /dev/null
+++ b/dev-perl/Sys-Virt/Sys-Virt-10.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Packages which get releases together:
+# app-emacs/nxml-libvirt-schemas
+# dev-python/libvirt-python
+# dev-perl/Sys-Virt
+# app-emulation/libvirt
+# Please bump them together!
+
+DIST_AUTHOR=DANBERR
+DIST_VERSION=v${PV}
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="API for using the libvirt library from Perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-emulation/libvirt-${PV}
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-CBuilder
+ dev-perl/Module-Build
+ virtual/pkgconfig
+ test? (
+ dev-perl/CPAN-Changes
+ dev-perl/Test-More-UTF8
+ dev-perl/Test-Pod-Coverage
+ dev-perl/XML-XPath
+ virtual/perl-Test-Simple
+ virtual/perl-Time-HiRes
+ )"
+DEPEND="
+ >=app-emulation/libvirt-${PV}
+"