summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-01-15 17:32:50 +0100
committerPacho Ramos <pacho@gentoo.org>2017-01-15 17:44:36 +0100
commit4d34d757998017cba453361a9c0363444eb33a19 (patch)
treed6d62d04c828405cec795f2fbb060f6fdbe9f5c1
parentgnome2.eclass: Allow to decide more easily if we can run eautoreconf OR only ... (diff)
downloadgentoo-4d34d757998017cba453361a9c0363444eb33a19.tar.gz
gentoo-4d34d757998017cba453361a9c0363444eb33a19.tar.bz2
gentoo-4d34d757998017cba453361a9c0363444eb33a19.zip
net-libs/phodav: Version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--net-libs/phodav/Manifest1
-rw-r--r--net-libs/phodav/phodav-2.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-libs/phodav/Manifest b/net-libs/phodav/Manifest
index e190627f2f6d..4a563ebd888c 100644
--- a/net-libs/phodav/Manifest
+++ b/net-libs/phodav/Manifest
@@ -1 +1,2 @@
DIST phodav-2.0.tar.xz 277672 SHA256 53b42faf2d6edfb0072dbbbe9b8360d8603cca2cacd142df8d1781b9ba0cb9ed SHA512 4da0f3ef7ce2ffd89e43569ad00456f9580f4005a6830a8cc36a7787cc9e06d285326376373a0d690a1868b1c10da0f3ba49b4eb8dcff3042f5c64cbe1fe0aba WHIRLPOOL 5d1ba19f502a72a86e7dbf47ca43cd5d711241fcdb936364c98de88df57cb49db88cdd0768c133bb936c40be98107f06d8b6d8f8cb1b51d2a05e33b83d36f8a4
+DIST phodav-2.1.tar.xz 293128 SHA256 da6073440b4cfd63f4d65b17e1a2a35ff501c7c940591da4533a03c2233ab898 SHA512 e43bd4c9ed97b7454e8452246c37211905b4cff430e91f3d2d36182736e1b8924d6ad477f58f110c98b85f02c085cd12c099020a0bea8abb19e65a9d52e1f4a8 WHIRLPOOL 4091fb0ac23b6a57c385054afa66a61eb038a37593167d888755dad38894898b45d7fcab6fa6d7582e4e2c5f0879e1ac782df2efc03e7e4372ac0a3341a4b10d
diff --git a/net-libs/phodav/phodav-2.1.ebuild b/net-libs/phodav/phodav-2.1.ebuild
new file mode 100644
index 000000000000..581ca52a03ef
--- /dev/null
+++ b/net-libs/phodav/phodav-2.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit autotools gnome2 systemd udev
+
+DESCRIPTION="WebDav server implementation using libsoup"
+HOMEPAGE="https://wiki.gnome.org/phodav"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="spice systemd zeroconf"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=net-libs/libsoup-2.48:2.4
+ dev-libs/libxml2
+ zeroconf? ( net-dns/avahi )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ >=dev-util/intltool-0.40.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --program-suffix=-${SLOT} \
+ $(use_with zeroconf avahi) \
+ --with-udevdir=$(get_udevdir) \
+ --with-systemdsystemunitdir=$(systemd_get_systemunitdir)
+
+ if ! use zeroconf ; then
+ sed -i -e 's|avahi-daemon.service||' data/spice-webdavd.service || die
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use spice ; then
+ if ! use systemd ; then
+ newinitd "${FILESDIR}/spice-webdavd.initd" spice-webdavd
+ udev_dorules "${FILESDIR}/70-spice-webdavd.rules"
+ rm -r "${D}$(systemd_get_unitdir)" || die
+ fi
+ else
+ rm -r "${D}"{/usr/sbin,$(get_udevdir),$(systemd_get_systemunitdir)} || die
+ fi
+}