summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-10-05 17:55:31 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-10-10 10:49:14 -0400
commit4d38a64828776c4aa191dcc9a6dcbde046fcbc25 (patch)
tree7129bd5acfd28c47c0f6f151c93ca9ca4c84c4e6
parentdev-python/PyQt6: pin 6.5.2-r0 to <Qt6.6 for bluetooth+sql (diff)
downloadgentoo-4d38a64828776c4aa191dcc9a6dcbde046fcbc25.tar.gz
gentoo-4d38a64828776c4aa191dcc9a6dcbde046fcbc25.tar.bz2
gentoo-4d38a64828776c4aa191dcc9a6dcbde046fcbc25.zip
dev-python/PyQt6: fix USE=sql build with qt6.6
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-python/PyQt6/PyQt6-6.5.2-r1.ebuild4
-rw-r--r--dev-python/PyQt6/files/PyQt6-6.5.2-qt660.patch19
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/PyQt6/PyQt6-6.5.2-r1.ebuild b/dev-python/PyQt6/PyQt6-6.5.2-r1.ebuild
index 08010f0076ec..0cf7208d441f 100644
--- a/dev-python/PyQt6/PyQt6-6.5.2-r1.ebuild
+++ b/dev-python/PyQt6/PyQt6-6.5.2-r1.ebuild
@@ -81,6 +81,10 @@ BDEPEND="
dbus? ( virtual/pkgconfig )
"
+PATCHES=(
+ "${FILESDIR}"/${P}-qt660.patch
+)
+
src_prepare() {
default
diff --git a/dev-python/PyQt6/files/PyQt6-6.5.2-qt660.patch b/dev-python/PyQt6/files/PyQt6-6.5.2-qt660.patch
new file mode 100644
index 000000000000..1b5b4e2667eb
--- /dev/null
+++ b/dev-python/PyQt6/files/PyQt6-6.5.2-qt660.patch
@@ -0,0 +1,19 @@
+Bit is removed in Qt6.6, fixes build with USE=sql ahead of next release.
+
+USE=bluetooth is still broken, but is not essential (no revdeps), and
+can instead be masked for the time being.
+--- a/sip/QtCore/QtCoremod.sip
++++ b/sip/QtCore/QtCoremod.sip
+@@ -24,3 +24,3 @@
+
+-%Timeline {Qt_6_0_0 Qt_6_1_0 Qt_6_2_0 Qt_6_3_0 Qt_6_4_0 Qt_6_5_0}
++%Timeline {Qt_6_0_0 Qt_6_1_0 Qt_6_2_0 Qt_6_3_0 Qt_6_4_0 Qt_6_5_0 Qt_6_6_0}
+
+--- a/sip/QtSql/qsqlresult.sip
++++ b/sip/QtSql/qsqlresult.sip
+@@ -65,3 +65,5 @@
+ int boundValueCount() const;
++%If (- Qt_6_6_0)
+ QList<QVariant> &boundValues() const;
++%End
+ QString executedQuery() const;