summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <crabbedhaloablution@icloud.com>2020-12-13 22:57:41 +0100
committerMike Gilbert <floppym@gentoo.org>2020-12-13 17:38:38 -0500
commit4d73470d3723db147f3ed35a3da90bf6903a3b49 (patch)
treee005896f6b09d9406daa4c68c5bef690a89e95d1
parentdev-cpp/sparsehash: x86 stable (bug #759589) (diff)
downloadgentoo-4d73470d3723db147f3ed35a3da90bf6903a3b49.tar.gz
gentoo-4d73470d3723db147f3ed35a3da90bf6903a3b49.tar.bz2
gentoo-4d73470d3723db147f3ed35a3da90bf6903a3b49.zip
dev-python/subunit: remove -Werror from configure.ac
Closes: https://bugs.gentoo.org/744313 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Peter Alfredsen <crabbedhaloablution@icloud.com> Signed-off-by: Mike Gilbert <floppym@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/18644
-rw-r--r--dev-python/subunit/files/subunit-1.4.0-werror.patch34
-rw-r--r--dev-python/subunit/subunit-1.4.0.ebuild5
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-python/subunit/files/subunit-1.4.0-werror.patch b/dev-python/subunit/files/subunit-1.4.0-werror.patch
new file mode 100644
index 000000000000..99b8b8d20453
--- /dev/null
+++ b/dev-python/subunit/files/subunit-1.4.0-werror.patch
@@ -0,0 +1,34 @@
+# https://bugs.gentoo.org/744313
+diff -NrU5 subunit-1.4.0.orig/configure.ac subunit-1.4.0/configure.ac
+--- subunit-1.4.0.orig/configure.ac 2020-12-13 22:03:01.225671695 +0100
++++ subunit-1.4.0/configure.ac 2020-12-13 22:03:26.899752669 +0100
+@@ -4,11 +4,11 @@
+ m4_define([SUBUNIT_VERSION],
+ m4_defn([SUBUNIT_MAJOR_VERSION]).m4_defn([SUBUNIT_MINOR_VERSION]).m4_defn([SUBUNIT_MICRO_VERSION]))
+ AC_PREREQ([2.59])
+ AC_INIT([subunit], [SUBUNIT_VERSION], [subunit-dev@lists.launchpad.net])
+ AC_CONFIG_SRCDIR([c/lib/child.c])
+-AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects])
++AM_INIT_AUTOMAKE([-Wall foreign subdir-objects])
+ AC_CONFIG_MACRO_DIR([m4])
+ [SUBUNIT_MAJOR_VERSION]=SUBUNIT_MAJOR_VERSION
+ [SUBUNIT_MINOR_VERSION]=SUBUNIT_MINOR_VERSION
+ [SUBUNIT_MICRO_VERSION]=SUBUNIT_MICRO_VERSION
+ [SUBUNIT_VERSION]=SUBUNIT_VERSION
+@@ -26,14 +26,14 @@
+ AC_PROG_LIBTOOL
+ AM_PATH_PYTHON
+
+ AS_IF([test "$GCC" = "yes"],
+ [
+- SUBUNIT_CFLAGS="-Wall -Werror -Wextra -Wstrict-prototypes "
++ SUBUNIT_CFLAGS="-Wall -Wextra -Wstrict-prototypes "
+ SUBUNIT_CFLAGS="$SUBUNIT_CFLAGS -Wmissing-prototypes -Wwrite-strings "
+ SUBUNIT_CFLAGS="$SUBUNIT_CFLAGS -Wno-variadic-macros "
+- SUBUNIT_CXXFLAGS="-Wall -Werror -Wextra -Wwrite-strings -Wno-variadic-macros"
++ SUBUNIT_CXXFLAGS="-Wall -Wextra -Wwrite-strings -Wno-variadic-macros"
+ ])
+
+ AM_CFLAGS="$SUBUNIT_CFLAGS -I\$(top_srcdir)/c/include"
+ AM_CXXFLAGS="$SUBUNIT_CXXFLAGS -I\$(top_srcdir)/c/include"
+ AC_SUBST(AM_CFLAGS)
diff --git a/dev-python/subunit/subunit-1.4.0.ebuild b/dev-python/subunit/subunit-1.4.0.ebuild
index 0719cf5c65f3..39cfb5fff590 100644
--- a/dev-python/subunit/subunit-1.4.0.ebuild
+++ b/dev-python/subunit/subunit-1.4.0.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6..9} pypy3 )
-inherit distutils-r1 multilib-minimal
+inherit distutils-r1 multilib-minimal autotools
DESCRIPTION="A streaming protocol for test results"
HOMEPAGE="https://launchpad.net/subunit https://pypi.org/project/python-subunit/"
@@ -34,6 +34,8 @@ DEPEND="
dev-python/testscenarios[${PYTHON_USEDEP}]
)"
+PATCHES=( "${FILESDIR}/${P}-werror.patch" )
+
src_prepare() {
sed -i -e 's/os.chdir(os.path.dirname(__file__))//' setup.py || die
@@ -46,6 +48,7 @@ src_prepare() {
distutils-r1_src_prepare
multilib_copy_sources
+ eautoreconf
}
multilib_src_configure() {