summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2024-05-19 12:22:47 -0400
committerCraig Andrews <candrews@gentoo.org>2024-05-19 12:22:47 -0400
commit4d784459f69b194449a6e7e19555ea1e8da8abdc (patch)
tree39e6c8e714036183c5e2d287f48c709042653946
parentwww-apps/jellyfin-bin: drop 10.9.1 (diff)
downloadgentoo-4d784459f69b194449a6e7e19555ea1e8da8abdc.tar.gz
gentoo-4d784459f69b194449a6e7e19555ea1e8da8abdc.tar.bz2
gentoo-4d784459f69b194449a6e7e19555ea1e8da8abdc.zip
mail-client/roundcube: add 1.6.7
Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--mail-client/roundcube/Manifest1
-rw-r--r--mail-client/roundcube/roundcube-1.6.7.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index e736a762aa30..f58b3703ee97 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -8,3 +8,4 @@ DIST roundcubemail-1.6.3-complete.tar.gz 6026670 BLAKE2B f3108c5040a912ffdca83a0
DIST roundcubemail-1.6.4-complete.tar.gz 6027429 BLAKE2B f83ee7662dfa6a27e6aae97f90e1af80fa5d68927a0336dd3dab84f438e88921cb60059d41256daa52eac44fff07673559a21c860b01ebc82747fe021b2fadda SHA512 ccfd6828ed0f9a25c3144133a9a0f091b7ef76251e74422fe90dc1eb6fdddee8522902869d97609cd594f0977ecb6eb7402378d390ae33d907d154a24a607f85
DIST roundcubemail-1.6.5-complete.tar.gz 6028873 BLAKE2B 70959d985130d67d67fa0f488c5468684a88c3537b902e1201cd672b5d79823160cea616dd11127f32c2ae8ce19f6fb643eff554e03616c6e8d6813e3ceccd3f SHA512 d5d108045dc0afcc1fda077cac82f3aef274702727d45395744a3228c2a0429199d411f1988fc3f8317040ce65735ba423e8a1a33bad77220d63821e8b29ae08
DIST roundcubemail-1.6.6-complete.tar.gz 5895753 BLAKE2B 73cccb6393a4eacca105216f8926eeac712850a3eb387249b8b037b7a6df89ee06423e05fbe0bbabae30233cde69a1201758301af4fe19985d33a3e2fbfc7210 SHA512 e5d7b187c444c0aec231c41d8c4cc80c388d86cc5d6689d5183a61c8913749239c5efcad5725fbb97efcdcaf2dd0235cd6a827b3deb94065da42dbb03a9bca6b
+DIST roundcubemail-1.6.7-complete.tar.gz 5899345 BLAKE2B c22803f3651c32f863081afe28d05e4b7918ba0cb1238c11de646a0fe3a16a6faff633a3a193a5813a50be710a71a8900d049f0e628661b6c7c036c0d69055ab SHA512 aedc940e769e881d448eced2ef0b603c87f9a9e18624cae4d14a946e6f9509c827f75e6fb294a760970e37caa9ab0bfb0a7ec8843b12542f59f350948d2d8d3b
diff --git a/mail-client/roundcube/roundcube-1.6.7.ebuild b/mail-client/roundcube/roundcube-1.6.7.ebuild
new file mode 100644
index 000000000000..e8f09db98c3b
--- /dev/null
+++ b/mail-client/roundcube/roundcube-1.6.7.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_PV=${PV/_/-}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="https://roundcube.net"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+
+IUSE="change-password enigma exif fileinfo ldap mysql postgres sqlite ssl spell zip"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+RDEPEND="
+ ${DEPEND}
+ >=dev-lang/php-7.4.0[exif?,fileinfo?,filter,gd,iconv,intl,json(+),ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml,zip?]
+ virtual/httpd-php
+ change-password? (
+ dev-lang/php[sockets]
+ )
+ enigma? (
+ app-crypt/gnupg
+ )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ spell? ( dev-lang/php[curl,spell] )
+"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/roundcube/roundcubemail"
+ EGIT_BRANCH="master"
+ BDEPEND="${BDEPEND}
+ app-arch/unzip
+ dev-php/composer
+ net-misc/curl"
+else
+ SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${MY_PV}/${MY_P}-complete.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+src_unpack() {
+ if [[ "${PV}" == *9999* ]]; then
+ git-r3_src_unpack
+ pushd "${S}" > /dev/null || die
+ rm Makefile || die
+ mv composer.json-dist composer.json || die
+ composer install --no-dev || die
+ ./bin/install-jsdeps.sh || die
+ popd > /dev/null || die
+ else
+ default
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.md INSTALL README.md UPGRADING SECURITY.md
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+ webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE_complete.txt"
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "You can review the post-upgrade instructions at:"
+ elog "${EROOT}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
+ fi
+}