summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2022-08-17 07:09:20 -0400
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-18 19:32:37 +0300
commit4d7e0a38f3df682f7a24eb7f00b5a4c09f2b60f6 (patch)
tree8092fce2a436d6c29d8391fb3665ad5e0f7cecb7
parentapp-editor/vscodium: disable update server on install (diff)
downloadgentoo-4d7e0a38.tar.gz
gentoo-4d7e0a38.tar.bz2
gentoo-4d7e0a38.zip
app-editor/vscode: disable update server on install
Remove the reference to update server which will disable automatic update check/notification. Signed-off-by: Joe Kappus <joe@wt.gd> Closes: https://github.com/gentoo/gentoo/pull/26897 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--app-editors/vscode/vscode-1.70.0-r1.ebuild (renamed from app-editors/vscode/vscode-1.70.0.ebuild)3
-rw-r--r--app-editors/vscode/vscode-1.70.1-r1.ebuild (renamed from app-editors/vscode/vscode-1.70.1.ebuild)3
2 files changed, 6 insertions, 0 deletions
diff --git a/app-editors/vscode/vscode-1.70.0.ebuild b/app-editors/vscode/vscode-1.70.0-r1.ebuild
index 9eed84dd6b73..00595b2ae2a7 100644
--- a/app-editors/vscode/vscode-1.70.0.ebuild
+++ b/app-editors/vscode/vscode-1.70.0-r1.ebuild
@@ -96,6 +96,9 @@ src_install() {
# Cleanup
rm -r ./resources/app/LICENSES.chromium.html ./resources/app/LICENSE.rtf ./resources/app/licenses || die
+ # Disable update server
+ sed -i "/updateUrl/d" ${S}/resources/app/product.json || die
+
# Install
pax-mark m code
insinto "/opt/${PN}"
diff --git a/app-editors/vscode/vscode-1.70.1.ebuild b/app-editors/vscode/vscode-1.70.1-r1.ebuild
index 9eed84dd6b73..00595b2ae2a7 100644
--- a/app-editors/vscode/vscode-1.70.1.ebuild
+++ b/app-editors/vscode/vscode-1.70.1-r1.ebuild
@@ -96,6 +96,9 @@ src_install() {
# Cleanup
rm -r ./resources/app/LICENSES.chromium.html ./resources/app/LICENSE.rtf ./resources/app/licenses || die
+ # Disable update server
+ sed -i "/updateUrl/d" ${S}/resources/app/product.json || die
+
# Install
pax-mark m code
insinto "/opt/${PN}"