summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-08-16 23:34:17 -0400
committerBrian Evans <grknight@gentoo.org>2018-08-16 23:34:43 -0400
commit4d92f97cf68a420fa8dd795ac86ed2df05adab35 (patch)
tree181687e402efb354d20d752f5ffaeb38b535ec07
parentdev-lang/php: Drop old (diff)
downloadgentoo-4d92f97c.tar.gz
gentoo-4d92f97c.tar.bz2
gentoo-4d92f97c.zip
dev-lang/php: Drop versionator for eapi7-ver
Package-Manager: Portage-2.3.46, Repoman-2.3.10
-rw-r--r--dev-lang/php/php-5.6.36.ebuild6
-rw-r--r--dev-lang/php/php-5.6.37.ebuild6
-rw-r--r--dev-lang/php/php-7.0.29.ebuild6
-rw-r--r--dev-lang/php/php-7.0.30.ebuild6
-rw-r--r--dev-lang/php/php-7.0.31.ebuild6
-rw-r--r--dev-lang/php/php-7.1.16.ebuild6
-rw-r--r--dev-lang/php/php-7.1.18.ebuild6
-rw-r--r--dev-lang/php/php-7.1.20.ebuild6
8 files changed, 24 insertions, 24 deletions
diff --git a/dev-lang/php/php-5.6.36.ebuild b/dev-lang/php/php-5.6.36.ebuild
index fe5b563b7ea5..4721afbce53e 100644
--- a/dev-lang/php/php-5.6.36.ebuild
+++ b/dev-lang/php/php-5.6.36.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit autotools flag-o-matic versionator systemd
+inherit autotools flag-o-matic eapi7-ver systemd
DESCRIPTION="The PHP language runtime engine"
HOMEPAGE="https://secure.php.net/"
@@ -17,7 +17,7 @@ LICENSE="PHP-3.01
gd? ( gd )
unicode? ( BSD-2 LGPL-2.1 )"
-SLOT="$(get_version_component_range 1-2)"
+SLOT="$(ver_cut 1-2)"
KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
# We can build the following SAPIs in the given order
@@ -174,7 +174,7 @@ REQUIRED_USE="
sharedmem? ( !threads )
"
-PHP_MV="$(get_major_version)"
+PHP_MV="$(ver_cut 1)"
php_install_ini() {
local phpsapi="${1}"
diff --git a/dev-lang/php/php-5.6.37.ebuild b/dev-lang/php/php-5.6.37.ebuild
index deec25b7c9a3..56adfd728558 100644
--- a/dev-lang/php/php-5.6.37.ebuild
+++ b/dev-lang/php/php-5.6.37.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit autotools flag-o-matic versionator systemd
+inherit autotools flag-o-matic eapi7-ver systemd
DESCRIPTION="The PHP language runtime engine"
HOMEPAGE="https://secure.php.net/"
@@ -17,7 +17,7 @@ LICENSE="PHP-3.01
gd? ( gd )
unicode? ( BSD-2 LGPL-2.1 )"
-SLOT="$(get_version_component_range 1-2)"
+SLOT="$(ver_cut 1-2)"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
# We can build the following SAPIs in the given order
@@ -174,7 +174,7 @@ REQUIRED_USE="
sharedmem? ( !threads )
"
-PHP_MV="$(get_major_version)"
+PHP_MV="$(ver_cut 1)"
php_install_ini() {
local phpsapi="${1}"
diff --git a/dev-lang/php/php-7.0.29.ebuild b/dev-lang/php/php-7.0.29.ebuild
index 08da09b6482b..94a37d5d0025 100644
--- a/dev-lang/php/php-7.0.29.ebuild
+++ b/dev-lang/php/php-7.0.29.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit flag-o-matic versionator systemd
+inherit flag-o-matic eapi7-ver systemd
DESCRIPTION="The PHP language runtime engine"
HOMEPAGE="https://secure.php.net/"
@@ -17,7 +17,7 @@ LICENSE="PHP-3.01
gd? ( gd )
unicode? ( BSD-2 LGPL-2.1 )"
-SLOT="$(get_version_component_range 1-2)"
+SLOT="$(ver_cut 1-2)"
KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
# We can build the following SAPIs in the given order
@@ -171,7 +171,7 @@ PATCHES=(
"${FILESDIR}/php-freetype-2.9.1.patch"
)
-PHP_MV="$(get_major_version)"
+PHP_MV="$(ver_cut 1)"
php_install_ini() {
local phpsapi="${1}"
diff --git a/dev-lang/php/php-7.0.30.ebuild b/dev-lang/php/php-7.0.30.ebuild
index 08da09b6482b..94a37d5d0025 100644
--- a/dev-lang/php/php-7.0.30.ebuild
+++ b/dev-lang/php/php-7.0.30.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit flag-o-matic versionator systemd
+inherit flag-o-matic eapi7-ver systemd
DESCRIPTION="The PHP language runtime engine"
HOMEPAGE="https://secure.php.net/"
@@ -17,7 +17,7 @@ LICENSE="PHP-3.01
gd? ( gd )
unicode? ( BSD-2 LGPL-2.1 )"
-SLOT="$(get_version_component_range 1-2)"
+SLOT="$(ver_cut 1-2)"
KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
# We can build the following SAPIs in the given order
@@ -171,7 +171,7 @@ PATCHES=(
"${FILESDIR}/php-freetype-2.9.1.patch"
)
-PHP_MV="$(get_major_version)"
+PHP_MV="$(ver_cut 1)"
php_install_ini() {
local phpsapi="${1}"
diff --git a/dev-lang/php/php-7.0.31.ebuild b/dev-lang/php/php-7.0.31.ebuild
index b88f71d861d2..aeaedb772a11 100644
--- a/dev-lang/php/php-7.0.31.ebuild
+++ b/dev-lang/php/php-7.0.31.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit flag-o-matic versionator systemd
+inherit flag-o-matic eapi7-ver systemd
DESCRIPTION="The PHP language runtime engine"
HOMEPAGE="https://secure.php.net/"
@@ -17,7 +17,7 @@ LICENSE="PHP-3.01
gd? ( gd )
unicode? ( BSD-2 LGPL-2.1 )"
-SLOT="$(get_version_component_range 1-2)"
+SLOT="$(ver_cut 1-2)"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
# We can build the following SAPIs in the given order
@@ -171,7 +171,7 @@ PATCHES=(
"${FILESDIR}/php-freetype-2.9.1.patch"
)
-PHP_MV="$(get_major_version)"
+PHP_MV="$(ver_cut 1)"
php_install_ini() {
local phpsapi="${1}"
diff --git a/dev-lang/php/php-7.1.16.ebuild b/dev-lang/php/php-7.1.16.ebuild
index da637b55abbd..4acba555659f 100644
--- a/dev-lang/php/php-7.1.16.ebuild
+++ b/dev-lang/php/php-7.1.16.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit flag-o-matic versionator systemd
+inherit flag-o-matic eapi7-ver systemd
DESCRIPTION="The PHP language runtime engine"
HOMEPAGE="https://secure.php.net/"
@@ -17,7 +17,7 @@ LICENSE="PHP-3.01
gd? ( gd )
unicode? ( BSD-2 LGPL-2.1 )"
-SLOT="$(get_version_component_range 1-2)"
+SLOT="$(ver_cut 1-2)"
KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
# We can build the following SAPIs in the given order
@@ -153,7 +153,7 @@ PATCHES=(
"${FILESDIR}/php-freetype-2.9.1.patch"
)
-PHP_MV="$(get_major_version)"
+PHP_MV="$(ver_cut 1)"
php_install_ini() {
local phpsapi="${1}"
diff --git a/dev-lang/php/php-7.1.18.ebuild b/dev-lang/php/php-7.1.18.ebuild
index 9a6345b2fbb4..a9061a4a930f 100644
--- a/dev-lang/php/php-7.1.18.ebuild
+++ b/dev-lang/php/php-7.1.18.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit flag-o-matic versionator systemd
+inherit flag-o-matic eapi7-ver systemd
DESCRIPTION="The PHP language runtime engine"
HOMEPAGE="https://secure.php.net/"
@@ -17,7 +17,7 @@ LICENSE="PHP-3.01
gd? ( gd )
unicode? ( BSD-2 LGPL-2.1 )"
-SLOT="$(get_version_component_range 1-2)"
+SLOT="$(ver_cut 1-2)"
KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
# We can build the following SAPIs in the given order
@@ -151,7 +151,7 @@ PATCHES=(
"${FILESDIR}/php-freetype-2.9.1.patch"
)
-PHP_MV="$(get_major_version)"
+PHP_MV="$(ver_cut 1)"
php_install_ini() {
local phpsapi="${1}"
diff --git a/dev-lang/php/php-7.1.20.ebuild b/dev-lang/php/php-7.1.20.ebuild
index d649e1715b3a..46badcaed5fe 100644
--- a/dev-lang/php/php-7.1.20.ebuild
+++ b/dev-lang/php/php-7.1.20.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit flag-o-matic versionator systemd
+inherit flag-o-matic eapi7-ver systemd
DESCRIPTION="The PHP language runtime engine"
HOMEPAGE="https://secure.php.net/"
@@ -17,7 +17,7 @@ LICENSE="PHP-3.01
gd? ( gd )
unicode? ( BSD-2 LGPL-2.1 )"
-SLOT="$(get_version_component_range 1-2)"
+SLOT="$(ver_cut 1-2)"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
# We can build the following SAPIs in the given order
@@ -148,7 +148,7 @@ PATCHES=(
"${FILESDIR}/php-freetype-2.9.1.patch"
)
-PHP_MV="$(get_major_version)"
+PHP_MV="$(ver_cut 1)"
php_install_ini() {
local phpsapi="${1}"