summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-07-28 14:16:08 +0200
committerJakov Smolić <jsmolic@gentoo.org>2022-07-28 14:17:30 +0200
commit4da0feb9792e14e7e6ce75a71945ed5ff5b32715 (patch)
tree052cf566e7eeaf40cc2d5f6c2d4de40ca192a410
parentapp-portage/gentoopm: add pypi upstream metadata (diff)
downloadgentoo-4da0feb9792e14e7e6ce75a71945ed5ff5b32715.tar.gz
gentoo-4da0feb9792e14e7e6ce75a71945ed5ff5b32715.tar.bz2
gentoo-4da0feb9792e14e7e6ce75a71945ed5ff5b32715.zip
dev-util/maturin: Disable rustls on riscv too in 0.13.1
Bug: https://bugs.gentoo.org/859577 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--dev-util/maturin/maturin-0.13.1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-util/maturin/maturin-0.13.1.ebuild b/dev-util/maturin/maturin-0.13.1.ebuild
index 1d9dbacce256..d63cc20f6be5 100644
--- a/dev-util/maturin/maturin-0.13.1.ebuild
+++ b/dev-util/maturin/maturin-0.13.1.ebuild
@@ -386,13 +386,13 @@ src_prepare() {
# ensure rustls is disabled on arches where ring crate is problematic,
# add as needed and keep in sync with src_configure below (bug #859577)
- if use ppc || use ppc64 || use s390; then
+ if use ppc || use ppc64 || use riscv || use s390; then
sed -i '/^if platform.machine/s/^if/if True or/' setup.py || die
fi
}
src_configure() {
- if use ppc || use ppc64 || use s390; then
+ if use ppc || use ppc64 || use riscv || use s390; then
local myfeatures=( upload log human-panic ) # sync with setup.py
cargo_src_configure --no-default-features
fi