summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-06-18 13:33:57 -0400
committerRick Farina <zerochaos@gentoo.org>2020-06-18 13:34:39 -0400
commit4da626b864fcba9e2f4a2bf66ffdfa6237508eca (patch)
treefbd95c3b1dbfdab108cc3fe7fd88c8637571030a
parentnet-p2p/syncthing: bump to 1.6.1 (diff)
downloadgentoo-4da626b864fcba9e2f4a2bf66ffdfa6237508eca.tar.gz
gentoo-4da626b864fcba9e2f4a2bf66ffdfa6237508eca.tar.bz2
gentoo-4da626b864fcba9e2f4a2bf66ffdfa6237508eca.zip
net-wireless/spectools: fixups
clean up for PR #15920 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
-rw-r--r--net-wireless/spectools/spectools-2016.01.1.ebuild13
-rw-r--r--net-wireless/spectools/spectools-9999.ebuild14
2 files changed, 15 insertions, 12 deletions
diff --git a/net-wireless/spectools/spectools-2016.01.1.ebuild b/net-wireless/spectools/spectools-2016.01.1.ebuild
index 97fef673112a..afc2d7508c68 100644
--- a/net-wireless/spectools/spectools-2016.01.1.ebuild
+++ b/net-wireless/spectools/spectools-2016.01.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools eutils flag-o-matic toolchain-funcs udev
+inherit autotools eutils toolchain-funcs udev flag-o-matic
MY_PN=${PN}
MY_PV=${PV/\./-}
@@ -12,7 +12,7 @@ MY_P="${MY_PN}-${MY_PV}"
S=${WORKDIR}/${MY_P}
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://www.kismetwireless.net/${PN}.git"
+ EGIT_REPO_URI="https://www.kismetwireless.net/git/${PN}.git"
inherit git-r3
else
SRC_URI="https://www.kismetwireless.net/code/${MY_P}.tar.xz"
@@ -37,14 +37,15 @@ RDEPEND="
DEPEND="${RDEPEND}
virtual/pkgconfig"
# Upstream has still not migrated to the libusb-1 line.
+# Maemo: Add hildon and bbus
src_prepare() {
- epatch "${FILESDIR}"/${PN}-2011.08.1_p20140618-tinfo.patch
+ eapply "${FILESDIR}"/${PN}-2011.08.1_p20140618-tinfo.patch
mv configure.{in,ac} || die
eautoreconf
-
# fix bug 577466 by restoring pre-GCC5 inline semantics
append-cflags -std=gnu89
+ default
}
# Please note that upstream removed the --with-gtk-version option
diff --git a/net-wireless/spectools/spectools-9999.ebuild b/net-wireless/spectools/spectools-9999.ebuild
index 4ad586a2983e..15ba5751de9d 100644
--- a/net-wireless/spectools/spectools-9999.ebuild
+++ b/net-wireless/spectools/spectools-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools eutils toolchain-funcs udev
+inherit autotools eutils toolchain-funcs udev flag-o-matic
MY_PN=${PN}
MY_PV=${PV/\./-}
@@ -12,9 +12,8 @@ MY_P="${MY_PN}-${MY_PV}"
S=${WORKDIR}/${MY_P}
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://www.kismetwireless.net/${PN}.git"
+ EGIT_REPO_URI="https://www.kismetwireless.net/git/${PN}.git"
inherit git-r3
- KEYWORDS=""
else
SRC_URI="https://www.kismetwireless.net/code/${MY_P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
@@ -41,9 +40,12 @@ DEPEND="${RDEPEND}
# Maemo: Add hildon and bbus
src_prepare() {
- epatch "${FILESDIR}"/${PN}-2011.08.1_p20140618-tinfo.patch
+ eapply "${FILESDIR}"/${PN}-2011.08.1_p20140618-tinfo.patch
mv configure.{in,ac} || die
eautoreconf
+ # fix bug 577466 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+ default
}
# Please note that upstream removed the --with-gtk-version option