summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-08 09:23:07 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-08 09:25:25 +0100
commit4dac870bc15eea4b2fc8d4dcbb44cb96f959f444 (patch)
tree90b40ffc8acf6cf450baf0fb21f26175563a0700
parentdev-python/flask-wtf: Bump to 1.0.0 (diff)
downloadgentoo-4dac870bc15eea4b2fc8d4dcbb44cb96f959f444.tar.gz
gentoo-4dac870bc15eea4b2fc8d4dcbb44cb96f959f444.tar.bz2
gentoo-4dac870bc15eea4b2fc8d4dcbb44cb96f959f444.zip
dev-python/wtforms: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/wtforms/Manifest1
-rw-r--r--dev-python/wtforms/wtforms-3.0.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/wtforms/Manifest b/dev-python/wtforms/Manifest
index 9351db2f731f..e757eba81cd5 100644
--- a/dev-python/wtforms/Manifest
+++ b/dev-python/wtforms/Manifest
@@ -1 +1,2 @@
DIST WTForms-2.3.3.tar.gz 162945 BLAKE2B 5f9f2c920ffc784c34d69f42cd259c1cb6007edbc99028bede98b7c3e24b8ba616b89eceac241cc9b20b241e758ee0c88a9c6736597ddc83c90542135a004fec SHA512 934cf1483beec37d698d13a81e44a733d082baad1f418d3087306fd908df809d37fffe000ed1ecabf65d2c31b57034bf6f25c3b77cfc5598ae1f65bf4a115fe5
+DIST WTForms-3.0.0.tar.gz 137053 BLAKE2B 518dfadf248a70fd0627a822c646e884709e295517bc187750e42296896db16dddbe95aa67bf29624147e77fc9db7deb46f3ebc3558801f7b8a5895116df1922 SHA512 dbed8706a317022be07f9568d11c7dab6021642957efab38e547b7b1b83b1ac8863a521b8fb0f5f4ec15cdc2966520a76d079a00ea88ce56f40a42b335fcfc6e
diff --git a/dev-python/wtforms/wtforms-3.0.0.ebuild b/dev-python/wtforms/wtforms-3.0.0.ebuild
new file mode 100644
index 000000000000..d8ec1d1bee74
--- /dev/null
+++ b/dev-python/wtforms/wtforms-3.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="WTForms"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flexible forms validation and rendering library for python web development"
+HOMEPAGE="https://wtforms.readthedocs.io/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/markupsafe[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-email-validator[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest