summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac.paragon@gmail.com>2021-03-28 14:50:11 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-04-10 11:31:31 +0300
commit4db13a86d16973ebc6ff65e41c6c220d901b2841 (patch)
treea9b144562cb6f0c01d1e4532d61c8c0caedb5a83
parentdev-java/slf4j-api: metadata (diff)
downloadgentoo-4db13a86d16973ebc6ff65e41c6c220d901b2841.tar.gz
gentoo-4db13a86d16973ebc6ff65e41c6c220d901b2841.tar.bz2
gentoo-4db13a86d16973ebc6ff65e41c6c220d901b2841.zip
media-gfx/xpaint: fix emerging with `rdlibtool`
`rdlibtool` is part of `sys-devel/slibtool` Closes: https://bugs.gentoo.org/778791 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Viorel Munteanu <ceamac.paragon@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--media-gfx/xpaint/files/xpaint-3.1.3-libtool-clang.patch37
-rw-r--r--media-gfx/xpaint/xpaint-3.1.3.ebuild1
2 files changed, 31 insertions, 7 deletions
diff --git a/media-gfx/xpaint/files/xpaint-3.1.3-libtool-clang.patch b/media-gfx/xpaint/files/xpaint-3.1.3-libtool-clang.patch
index 92ccb899ce16..9aef70c8a9a1 100644
--- a/media-gfx/xpaint/files/xpaint-3.1.3-libtool-clang.patch
+++ b/media-gfx/xpaint/files/xpaint-3.1.3-libtool-clang.patch
@@ -1,26 +1,51 @@
libtool doesn't work if compiling with clang. Need to add --tag=CC
-Also don't hardcode /usr/bin/tool in gentoo prefix
+Don't hardcode /usr/bin/libtool in gentoo prefix
See bug https://bugs.gentoo.org/731010
+
+rdlibtool needs to find system libtool in current directory
+See bug https://bugs.gentoo.org/778791
--- a/configure.ac
+++ b/configure.ac
-@@ -17,6 +17,9 @@
+@@ -17,6 +17,10 @@
AC_LANG_C
AM_PROG_AR
-+dnl search libtool
-+AC_PATH_PROG([PROGLIBTOOL], [libtool])
++dnl libtool
++LT_INIT
++AC_SUBST([LIBTOOL_DEPS])
+
## basic types
AC_TYPE_INT8_T
--- a/xpaintrw/Makefile.am
+++ b/xpaintrw/Makefile.am
-@@ -28,7 +28,7 @@
+@@ -28,7 +28,8 @@
xpaint_DEFINES = $(ARCH_DEFINES) $(EXTRA_DEFINES) $(XAWLIB_DEFINES)
-LIBTOOL = /usr/bin/libtool
-+LIBTOOL = @PROGLIBTOOL@ --tag=CC
++LIBTOOL = ../libtool
++AM_LIBTOOLFLAGS = --tag=CC
AM_CFLAGS = @X_CFLAGS@ @SPECIAL_CFLAGS@ $(xpaint_DEFINES)
AM_YFLAGS = -d
CLEANFILES =
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -53,12 +53,16 @@
+ dist_man_MANS = xpaint.1 imgmerge.1
+ AM_CFLAGS = @X_CFLAGS@ @SPECIAL_CFLAGS@ $(xpaint_DEFINES)
+ ACLOCAL_AMFLAGS = -I m4
+-BUILT_SOURCES = version.h DefaultRC.txt.h messages.h XPaint.ad.h xpaint.1
++BUILT_SOURCES = version.h DefaultRC.txt.h messages.h XPaint.ad.h xpaint.1 libtool
+ AM_YFLAGS = -d
+ CLEANFILES = preproc substads \
+ version.h DefaultRC.txt.h messages.h XPaint.ad.h xpaint.1
+ EXTRA_DIST =
+
++LIBTOOL_DEPS = @LIBTOOL_DEPS@
++libtool:
++ $(SHELL) ./config.status libtool
++
+ BASE_HDRS = bitmap.h color.h crc32.h \
+ Colormap.h ColormapP.h graphic.h hash.h image.h \
+ menu.h messages.h misc.h operation.h ops.h \
diff --git a/media-gfx/xpaint/xpaint-3.1.3.ebuild b/media-gfx/xpaint/xpaint-3.1.3.ebuild
index 131d8059027a..df08e4c0d858 100644
--- a/media-gfx/xpaint/xpaint-3.1.3.ebuild
+++ b/media-gfx/xpaint/xpaint-3.1.3.ebuild
@@ -40,7 +40,6 @@ DEPEND="${RDEPEND}"
BDEPEND="
sys-devel/bison
sys-devel/flex
- sys-devel/libtool
virtual/pkgconfig
x11-misc/imake
"