summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-11-04 02:15:59 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-11-04 02:15:59 +0100
commit4db476a705871670da77a00ae6d440c6ec070988 (patch)
treee4c36dbe48fa7c8a03da9d83310e9664c85538d0
parentdev-python/scipy: drop 1.9.1 (diff)
downloadgentoo-4db476a7.tar.gz
gentoo-4db476a7.tar.bz2
gentoo-4db476a7.zip
games-emulation/melonds: bump to 0.9.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--games-emulation/melonds/Manifest1
-rw-r--r--games-emulation/melonds/melonds-0.9.5.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/games-emulation/melonds/Manifest b/games-emulation/melonds/Manifest
index d2554b5a800c..6aaceabb1389 100644
--- a/games-emulation/melonds/Manifest
+++ b/games-emulation/melonds/Manifest
@@ -1,2 +1,3 @@
DIST melonDS-0.9.3.tar.gz 2241325 BLAKE2B 0ea7fbcce039a60a0553ae45d11f0b1550bfec2300faf1c99c3ee531bd5949c7293bec187fbf53e400bbb6280df29db141b2d1bcb294a8abf2eabb71993db686 SHA512 37f26f3a9784873ce1664645cea70049725367f5fe62f7c58842ebd5da2c73ffe423695dddb0ffd444bdf59df2a3fcd778cdf95b2bb083014b961fed282953f5
DIST melonDS-0.9.4_p1.tar.gz 2330696 BLAKE2B f118d067505d740fef2c9f3a7761580981d43c6c63f9bfb34f48cbc5c6932e5410ee31259845787262412b040a66c85cdd4298645e2060fc6c8821a89b314711 SHA512 76886ecfbabd00ae9261c33fcd4074b20e989f4357575bf68139538136fb0ba728d7590310ce4ae9c45670ee01ec315046f03f54e7ca9a359be202709b030f6d
+DIST melonDS-0.9.5.tar.gz 2496704 BLAKE2B ac6b75a74df266c6220a15c8775969f19bd6ef19946c913d49b642aa797ca6dc4cd956e7a840fbdbf572a9178a214314549cfe3fc4617a4f0f3877850c6818cd SHA512 115cf04e4e22a20016ac4f2946aef917e5c9566b1a5f18599f7b7c47b0ac71e3645157a8a21622ab83683848c57ab25e6d6fcff0df559087b56642d99ffe40ec
diff --git a/games-emulation/melonds/melonds-0.9.5.ebuild b/games-emulation/melonds/melonds-0.9.5.ebuild
new file mode 100644
index 000000000000..c5383c9da154
--- /dev/null
+++ b/games-emulation/melonds/melonds-0.9.5.ebuild
@@ -0,0 +1,87 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="melonDS"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake flag-o-matic readme.gentoo-r1 toolchain-funcs xdg
+
+DESCRIPTION="Nintendo DS emulator, sorta"
+HOMEPAGE="http://melonds.kuribo64.net
+ https://github.com/Arisotura/melonDS"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Arisotura/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/Arisotura/${MY_PN}/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+ S="${WORKDIR}"/${MY_P}
+ KEYWORDS="~amd64"
+fi
+
+IUSE="+jit +opengl"
+LICENSE="BSD-2 GPL-2 GPL-3 Unlicense"
+SLOT="0"
+
+# MelonDS bundles libteakra with many changes,
+# for now we have to block dev-libs/teakra
+RDEPEND="
+ !dev-libs/teakra
+ app-arch/libarchive
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-libs/libsdl2[sound,video]
+ net-libs/libpcap
+ net-libs/libslirp
+ opengl? ( media-libs/libepoxy )
+"
+DEPEND="${RDEPEND}"
+
+# used for JIT recompiler
+QA_EXECSTACK="usr/bin/melonDS"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="You need the following files in order to run melonDS:
+- bios7.bin
+- bios9.bin
+- firmware.bin
+- romlist.bin
+Place them in ~/.config/melonDS
+Those files can be found somewhere on the Internet ;-)"
+
+src_prepare() {
+ filter-lto
+ append-flags -fno-strict-aliasing
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_JIT=$(usex jit)
+ -DENABLE_OGLRENDERER=$(usex opengl)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ tc-export AR
+ cmake_src_compile
+}
+
+src_install() {
+ readme.gentoo_create_doc
+ cmake_src_install
+
+ dolib.so "${BUILD_DIR}"/src/teakra/src/libteakra.so
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ readme.gentoo_print_elog
+}