summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThamognya Kodi <contact@thamognya.com>2022-05-29 07:10:26 +0700
committerJoonas Niilola <juippis@gentoo.org>2022-06-12 10:11:34 +0300
commit4dc8be00543a8bc1b8c5d4dec1c4266da712c669 (patch)
tree942f6e48d0af5ec2edf0c3f228eaafa727367b5e
parentnet-misc/teamviewer: version bump to 15.30.3 (diff)
downloadgentoo-4dc8be00543a8bc1b8c5d4dec1c4266da712c669.tar.gz
gentoo-4dc8be00543a8bc1b8c5d4dec1c4266da712c669.tar.bz2
gentoo-4dc8be00543a8bc1b8c5d4dec1c4266da712c669.zip
dev-ml/react: bump to 1.2.2
Signed-off-by: Thamognya Kodi <contact@thamognya.com> Closes: https://github.com/gentoo/gentoo/pull/25668 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-ml/react/Manifest1
-rw-r--r--dev-ml/react/metadata.xml35
-rw-r--r--dev-ml/react/react-1.2.2.ebuild38
3 files changed, 58 insertions, 16 deletions
diff --git a/dev-ml/react/Manifest b/dev-ml/react/Manifest
index 6c88ce594eba..0de27a72b76d 100644
--- a/dev-ml/react/Manifest
+++ b/dev-ml/react/Manifest
@@ -1 +1,2 @@
DIST react-1.2.1.tbz 39184 BLAKE2B 0ad5fd576c08292011e6543462295a11b77048f59aaaf34726c078c654fba4a9b7dd0bb6a6579fad04a6cd217b29f4efc15de9b7d9b208c593b481610534d9c8 SHA512 60f8788cc820e2be5303caedc80a377c8e5deab170d0eb9df71ff99d6fc57f31357824522f973c6e0d6b3979b58272e7f90b829474a494b94565279c53e8fbb1
+DIST react-1.2.2.tbz 40013 BLAKE2B 302f480cf2cc88fc8a97b262d41809ed4fe904d3ea4cdec8ba80a8bdc99b3ffc1c9f19cf853c3d40587a34ba7608734e60ede5b756479676af95f9470e1badac SHA512 18cdd544d484222ba02db6bd9351571516532e7a1c107b59bbe39193837298f5c745eab6754f8bc6ff125b387be7018c6d6e6ac99f91925a5e4f53af688522b1
diff --git a/dev-ml/react/metadata.xml b/dev-ml/react/metadata.xml
index 9371e28a658c..e6107330d4f5 100644
--- a/dev-ml/react/metadata.xml
+++ b/dev-ml/react/metadata.xml
@@ -1,20 +1,23 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription lang="en">
- React is an OCaml module for functional reactive programming (FRP). It
- provides support to program with time varying values : applicative
- events and signals. React doesn't define any primitive event or
- signal, this lets the client chooses the concrete timeline.
-
- React is made of a single, independent, module and distributed under
- the new BSD license.
-
- Given an absolute notion of time Rtime helps you to manage a timeline
- and provides time stamp events, delayed events and delayed signals.
- </longdescription>
- <upstream>
- <remote-id type="github">dbuenzli/react</remote-id>
- </upstream>
+ <maintainer type="person" proxied="yes">
+ <name>Thamognya Kodi</name>
+ <email>contact@thamognya.com</email>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">React is an OCaml module for functional reactive programming (FRP). It
+ provides support to program with time varying values : applicative
+ events and signals. React doesn't define any primitive event or
+ signal, this lets the client chooses the concrete timeline.
+ React is made of a single, independent, module and distributed under
+ the new BSD license.
+ Given an absolute notion of time Rtime helps you to manage a timeline
+ and provides time stamp events, delayed events and delayed signals.</longdescription>
+ <upstream>
+ <remote-id type="github">dbuenzli/react</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-ml/react/react-1.2.2.ebuild b/dev-ml/react/react-1.2.2.ebuild
new file mode 100644
index 000000000000..a0f919852efe
--- /dev/null
+++ b/dev-ml/react/react-1.2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="OCaml module for functional reactive programming"
+HOMEPAGE="http://erratique.ch/software/react https://github.com/dbuenzli/react"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dbuenzli/react.git"
+else
+ SRC_URI="http://erratique.ch/software/react/releases/${P}.tbz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ >=dev-ml/topkg-0.9
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --tests $(usex test 'true' 'false') \
+ || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}