summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony Ryan <anthonyryan1@gmail.com>2023-12-14 12:47:25 -0500
committerSam James <sam@gentoo.org>2024-01-20 13:00:17 +0000
commit4dcd8465937fb217d84ad607587a406023192060 (patch)
tree8e6539bda85493e74f290a2067d822a9bb6d9daf
parentdev-php/pecl-xdiff: Add support for PHP 8.3 and remove old (diff)
downloadgentoo-4dcd8465937fb217d84ad607587a406023192060.tar.gz
gentoo-4dcd8465937fb217d84ad607587a406023192060.tar.bz2
gentoo-4dcd8465937fb217d84ad607587a406023192060.zip
dev-php/xhprof: add 2.3.9
Signed-off-by: Anthony Ryan <anthonyryan1@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34284 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-php/xhprof/Manifest1
-rw-r--r--dev-php/xhprof/xhprof-2.3.9.ebuild17
2 files changed, 18 insertions, 0 deletions
diff --git a/dev-php/xhprof/Manifest b/dev-php/xhprof/Manifest
index 6d88f3b33341..993f97faf8d3 100644
--- a/dev-php/xhprof/Manifest
+++ b/dev-php/xhprof/Manifest
@@ -1 +1,2 @@
DIST xhprof-2.3.5.tgz 842658 BLAKE2B 4392b521e8b4c10dc745bbd670c351231680e753251b1d1e3c7048e17fa5a88a6c79da39f3c50b8642ca0c1a5b9658e4dafe6ed4af3dc97c71265f021438fda9 SHA512 50ae6fb8d63ac8354b7887daecd1882f33e616cd1ef165b54d51f26fa93d2827f621e89d0d583979c453af5d66a83ddcbf0eb2d462df74ebb422294e601268f4
+DIST xhprof-2.3.9.tgz 843027 BLAKE2B be7c36d7b30f1efd1e3fb4d67f1d9ee8e23bb0e28f6bf9b8c00ee61154e753505e0935acf75c61d0806222a14d3203a4be1c0b4ef6b00f7d15aa9d35d99e410f SHA512 38a2609d961d908c6a4b5d1ff2085ffdad4a5f7d277705c826ae19e215660802528d606c5ee052f2e65255a7a85b2a9cb9038f4785c730ec468fc76dc7bcf5de
diff --git a/dev-php/xhprof/xhprof-2.3.9.ebuild b/dev-php/xhprof/xhprof-2.3.9.ebuild
new file mode 100644
index 000000000000..42bbc9840ab0
--- /dev/null
+++ b/dev-php/xhprof/xhprof-2.3.9.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PHP_EXT_S="${S}/extension"
+PHP_EXT_ECONF_ARGS=""
+USE_PHP="php8-1 php8-2 php8-3"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="A Hierarchical Profiler for PHP"
+HOMEPAGE="https://pecl.php.net/package/xhprof"
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"