summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-08-28 14:17:36 +0200
committerMarek Szuba <marecki@gentoo.org>2020-08-28 14:17:36 +0200
commit4dd259e91aa64316e138c4cd1c5bd38823bfc374 (patch)
treec7e1398fc74c194a162bdb135f7ebc89657239ce
parentnet-ftp/filezilla: bump to v3.50.0 (diff)
downloadgentoo-4dd259e91aa64316e138c4cd1c5bd38823bfc374.tar.gz
gentoo-4dd259e91aa64316e138c4cd1c5bd38823bfc374.tar.bz2
gentoo-4dd259e91aa64316e138c4cd1c5bd38823bfc374.zip
net-analyzer/nessus-bin: handle version updates properly
Nessus must be made aware of a new version of its core components having been installed. Do it the same way as upstream distro packages, i.e. use the undocumented nessuscli command 'install'. This is safe to do while nessusd-bin is running but it WILL be necessary to restart the service so that the dashboard is updated as well. In fact, Nessus UI will complain about the version discrepancy between the core and the dashboard until the service has been restarted. Closes: https://bugs.gentoo.org/739178 Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--net-analyzer/nessus-bin/nessus-bin-8.11.1-r1.ebuild (renamed from net-analyzer/nessus-bin/nessus-bin-8.11.1.ebuild)13
1 files changed, 7 insertions, 6 deletions
diff --git a/net-analyzer/nessus-bin/nessus-bin-8.11.1.ebuild b/net-analyzer/nessus-bin/nessus-bin-8.11.1-r1.ebuild
index 444f5c56b2c8..1e569f0e0f10 100644
--- a/net-analyzer/nessus-bin/nessus-bin-8.11.1.ebuild
+++ b/net-analyzer/nessus-bin/nessus-bin-8.11.1-r1.ebuild
@@ -50,15 +50,16 @@ src_install() {
}
pkg_postinst() {
+ # Actually update Nessus core components. According to upstream packages,
+ # harmless to invoke on fresh installations too - and it may make life easier
+ # for people who had restored Nessus state from backups, had it lying around
+ # from older installations and so on.
+ "${EROOT}"/opt/nessus/sbin/nessuscli install "${EROOT}"/opt/nessus/var/nessus/plugins-core.tar.gz
+
if [[ -z "${REPLACING_VERSIONS}" ]]; then
elog "To get started launch the nessusd-bin service, then point your Web browser to"
elog " https://<yourhost>:8834/"
else
- elog "You may want to restart the nessusd-bin service to use"
- elog "the new version of Nessus."
- elog "You also need to update your plugins. When ready, it's done like this:"
- elog "/etc/init.d/nessusd-bin stop"
- elog "/opt/nessus/sbin/nessuscli update --all"
- elog "/etc/init.d/nessusd-bin start"
+ elog "Please restart the nessusd-bin service to use the new version of Nessus"
fi
}