summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:42:47 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:52:59 +0200
commit4dd45fdea19c1d2a9574f253329d3e87fbddd166 (patch)
tree26779cc7b80754c3a9bb6125a9fc76cb6365adbc
parentdev-python/jinja: Remove redundant versions (diff)
downloadgentoo-4dd45fdea19c1d2a9574f253329d3e87fbddd166.tar.gz
gentoo-4dd45fdea19c1d2a9574f253329d3e87fbddd166.tar.bz2
gentoo-4dd45fdea19c1d2a9574f253329d3e87fbddd166.zip
dev-python/joblib: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/joblib/joblib-0.15.1-r1.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/joblib/joblib-0.15.1-r1.ebuild b/dev-python/joblib/joblib-0.15.1-r1.ebuild
deleted file mode 100644
index 23ccee52ebed..000000000000
--- a/dev-python/joblib/joblib-0.15.1-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Tools to provide lightweight pipelining in Python"
-HOMEPAGE="https://joblib.readthedocs.io/en/latest/
- https://github.com/joblib/joblib"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-
-RDEPEND="
- dev-python/cloudpickle[${PYTHON_USEDEP}]
- dev-python/loky[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/threadpoolctl[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx doc \
- 'dev-python/numpy' \
- 'dev-python/matplotlib' \
- 'dev-python/pillow' \
- 'dev-python/sphinx-gallery' \
- 'dev-python/numpydoc' \
- 'dev-python/pandas' \
- 'dev-python/lz4' \
- 'dev-python/distributed'
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # unbundle
- rm -r joblib/externals || die
- sed -e "s:'joblib.externals[^']*',\?::g" -i setup.py || die
- find -name '*.py' -exec \
- sed -e 's:\(joblib\)\?\.externals\.::' \
- -e 's:from \.externals ::' \
- -i {} + || die
-
- sed -e "s:'_static/joblib_logo_examples.png':'doc/_static/joblib_logo_examples.png':" \
- -i doc/conf.py || die
-
- # tries to fetch from the internet
- rm examples/compressors_comparison.py \
- examples/parallel/distributed_backend_simple.py || die
-
- distutils-r1_python_prepare_all
-}