summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-12-29 19:51:00 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2015-12-29 19:51:15 +0000
commit4e0515713cdef6345aeb04bc57df0468df492bed (patch)
treea7604e56b7a8e4290f6679b6a73002c9eeb8a951
parentdev-util/ninja: Support python3.5 (diff)
downloadgentoo-4e0515713cdef6345aeb04bc57df0468df492bed.tar.gz
gentoo-4e0515713cdef6345aeb04bc57df0468df492bed.tar.bz2
gentoo-4e0515713cdef6345aeb04bc57df0468df492bed.zip
media-video/libav: fix for libvpx-1.5.0, bug #565696
Pulled upstream patch as is. Reported-by: Peter Levine Bug: https://bugs.gentoo.org/565696 Package-Manager: portage-2.2.26
-rw-r--r--media-video/libav/files/libav-11.3-libvpx-1.5.0.patch47
-rw-r--r--media-video/libav/libav-11.3-r1.ebuild1
2 files changed, 48 insertions, 0 deletions
diff --git a/media-video/libav/files/libav-11.3-libvpx-1.5.0.patch b/media-video/libav/files/libav-11.3-libvpx-1.5.0.patch
new file mode 100644
index 000000000000..6844a152b7a5
--- /dev/null
+++ b/media-video/libav/files/libav-11.3-libvpx-1.5.0.patch
@@ -0,0 +1,47 @@
+https://bugs.gentoo.org/565696
+
+commit 4d05e9392f84702e3c833efa86e84c7f1cf5f612
+Author: James Zern <jzern@google.com>
+Date: Mon Oct 19 22:44:11 2015 -0700
+
+ libvpxenc: remove some unused ctrl id mappings
+
+ VP8E_UPD_ENTROPY, VP8E_UPD_REFERENCE, VP8E_USE_REFERENCE were removed
+ from libvpx and the remaining values were never used here
+
+ Reviewed-by: Michael Niedermayer <michael@niedermayer.cc>
+ Signed-off-by: James Zern <jzern@google.com>
+ Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
+
+diff --git a/libavcodec/libvpxenc.c b/libavcodec/libvpxenc.c
+index 563117f..d1e2523 100644
+--- a/libavcodec/libvpxenc.c
++++ b/libavcodec/libvpxenc.c
+@@ -71,23 +71,15 @@ typedef struct VP8EncoderContext {
+
+ /** String mappings for enum vp8e_enc_control_id */
+ static const char *const ctlidstr[] = {
+- [VP8E_UPD_ENTROPY] = "VP8E_UPD_ENTROPY",
+- [VP8E_UPD_REFERENCE] = "VP8E_UPD_REFERENCE",
+- [VP8E_USE_REFERENCE] = "VP8E_USE_REFERENCE",
+- [VP8E_SET_ROI_MAP] = "VP8E_SET_ROI_MAP",
+- [VP8E_SET_ACTIVEMAP] = "VP8E_SET_ACTIVEMAP",
+- [VP8E_SET_SCALEMODE] = "VP8E_SET_SCALEMODE",
++ [VP8E_SET_ARNR_MAXFRAMES] = "VP8E_SET_ARNR_MAXFRAMES",
++ [VP8E_SET_ARNR_STRENGTH] = "VP8E_SET_ARNR_STRENGTH",
++ [VP8E_SET_ARNR_TYPE] = "VP8E_SET_ARNR_TYPE",
+ [VP8E_SET_CPUUSED] = "VP8E_SET_CPUUSED",
++ [VP8E_SET_CQ_LEVEL] = "VP8E_SET_CQ_LEVEL",
+ [VP8E_SET_ENABLEAUTOALTREF] = "VP8E_SET_ENABLEAUTOALTREF",
+ [VP8E_SET_NOISE_SENSITIVITY] = "VP8E_SET_NOISE_SENSITIVITY",
+- [VP8E_SET_SHARPNESS] = "VP8E_SET_SHARPNESS",
+ [VP8E_SET_STATIC_THRESHOLD] = "VP8E_SET_STATIC_THRESHOLD",
+ [VP8E_SET_TOKEN_PARTITIONS] = "VP8E_SET_TOKEN_PARTITIONS",
+- [VP8E_GET_LAST_QUANTIZER] = "VP8E_GET_LAST_QUANTIZER",
+- [VP8E_SET_ARNR_MAXFRAMES] = "VP8E_SET_ARNR_MAXFRAMES",
+- [VP8E_SET_ARNR_STRENGTH] = "VP8E_SET_ARNR_STRENGTH",
+- [VP8E_SET_ARNR_TYPE] = "VP8E_SET_ARNR_TYPE",
+- [VP8E_SET_CQ_LEVEL] = "VP8E_SET_CQ_LEVEL",
+ };
+
+ static av_cold void log_encoder_error(AVCodecContext *avctx, const char *desc)
diff --git a/media-video/libav/libav-11.3-r1.ebuild b/media-video/libav/libav-11.3-r1.ebuild
index 4034d60e0800..ef7432570213 100644
--- a/media-video/libav/libav-11.3-r1.ebuild
+++ b/media-video/libav/libav-11.3-r1.ebuild
@@ -155,6 +155,7 @@ src_prepare() {
epatch_user
epatch "${WORKDIR}/0001-x86-Put-COPY3_IF_LT-under-HAVE_6REGS.patch"
+ epatch "${FILESDIR}"/${P}-libvpx-1.5.0.patch #565696
# if we have snapshot then we need to hardcode the version
if [[ ${PV%_p*} != ${PV} ]]; then