summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 00:34:45 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-09 02:05:06 -0500
commit4e052dbc6be67ff939b57ec13f2e39186e6c7e27 (patch)
treef22296b5296982a8d826d10c6fa64299013b39c5
parentdev-python/oslo-config: 6.8.1 bump (diff)
downloadgentoo-4e052dbc6be67ff939b57ec13f2e39186e6c7e27.tar.gz
gentoo-4e052dbc6be67ff939b57ec13f2e39186e6c7e27.tar.bz2
gentoo-4e052dbc6be67ff939b57ec13f2e39186e6c7e27.zip
dev-python/oslo-utils: 3.40.3 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/oslo-utils/Manifest1
-rw-r--r--dev-python/oslo-utils/oslo-utils-3.40.3.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/dev-python/oslo-utils/Manifest b/dev-python/oslo-utils/Manifest
index 6c2307872655..4f4f90199e74 100644
--- a/dev-python/oslo-utils/Manifest
+++ b/dev-python/oslo-utils/Manifest
@@ -1 +1,2 @@
DIST oslo-utils-3.36.4.tar.gz 87872 BLAKE2B 15f4fe90e5335cdf146ec582a506f2ab2bcae9989feca24caec7c12a4136767e93acb117345ce62013cde64938994eeb0c0809665cd155d5e0aaae7dc6aad879 SHA512 d5a81b68cc00c25eeb2e6d39b8fd4a47cb958c32e50471845b14a06cb5f420ac58986106893a27364adba968adc19f864624d69bae316202bdaf2c156458eac1
+DIST oslo-utils-3.40.3.tar.gz 90561 BLAKE2B 72c3361a291819e8d08f0c2087ad87a50848c73e9e349b330ad81225612446523a13bbe726fcbd27151baace0316f704878db9438930ee212a77757d67ca551e SHA512 893164fcb10d7912053666beb9caaad11c37c187b9d5182a3ffaf3282b9c97d9a9eeeb0cc9a4fdb68d3d3a82b14c7c9cef3c7a27d1395f20fc16de486ecaa49b
diff --git a/dev-python/oslo-utils/oslo-utils-3.40.3.ebuild b/dev-python/oslo-utils/oslo-utils-3.40.3.ebuild
new file mode 100644
index 000000000000..609fa75c5a52
--- /dev/null
+++ b/dev-python/oslo-utils/oslo-utils-3.40.3.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Utility library"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/eventlet-0.18.2[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.18.3[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.23.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.7[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ virtual/python-funcsigs[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+# Note: Tests fail due to requiring installation
+#
+# Installation appears to fail due to the use of namespace packages but root
+# cause was never truly established.
+#
+# Tests fail with:
+# ImportError: No module named 'oslo.utils
+
+#RESTRICT="test"
+
+python_test() {
+ distutils_install_for_testing
+
+ cd "${TEST_DIR}"/lib || die
+
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}