summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-04-19 17:45:40 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-04-19 17:47:31 -0500
commit4e10afe03c202f8a7c71fe8f33b0389f2e463942 (patch)
treecb305f5bcc82c45e0e18986423e3516215a8f5a3
parentapp-admin/puppetserver: 7.7.0 bump (diff)
downloadgentoo-4e10afe0.tar.gz
gentoo-4e10afe0.tar.bz2
gentoo-4e10afe0.zip
dev-ruby/puppetdb-termini: 7.10.1 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-7.10.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index f12b2e8323a7..224a53a6edf1 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1,2 +1,3 @@
+DIST puppetdb-termini_7.10.1-1stretch_all.deb 22156 BLAKE2B 52b1060fcf177b37229303ef93f90424f2b6b29eadf8041aa733d20f6b417c16e163891c44bc6f7845957ced10db132c705d6d6031041abace2f8f66f3d64964 SHA512 b273ac57558c9255d342010d9f3ada729596582311b3bbe658bf1505bd457041d0f5948c35c37bad585c931a66a66dcadcc71960de695c126715ef53d08295c5
DIST puppetdb-termini_7.9.0-1stretch_all.deb 21860 BLAKE2B e2ecc32f216a22d1c617d9d407d58512a2d84e2eb73ed37425ed16abc7948a8e6b8a0744798baf4282b5d43605e66cc8f5fb59e42eaffe10625d486e120e8d71 SHA512 e91cd0870d02fb690c0d9585b9d56b72e53c5f64ab5bec4631651326806a270f0c6601c77279d17b5182d73924a3782f2e1ca5fdf4cf03beac1b0e3e807b36db
DIST puppetdb-termini_7.9.2-1stretch_all.deb 22164 BLAKE2B fbdeb196815a09fc3b5658cf193d723bc0038ce0463cab3fa218bdc970d03828eeffa5a4756c4716afe6346a6aca2ea4ceb8c57ae4174cbae72773fffee634ce SHA512 5c399983118583d856c8160f8e21b646dbdaf56ba9044f7d5ac7a00cac14038b476b80074ea7bb696c0d9548cb50e03efc1119a32bade81532b6f10540a54d3d
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-7.10.1.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-7.10.1.ebuild
new file mode 100644
index 000000000000..a2bc85cce4e6
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-7.10.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="https://puppet.com/docs/puppetdb/latest/index.html"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}