summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-20 09:33:13 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-20 09:33:18 +0100
commit4e11438af326a6689764481c700797127c8ab0c9 (patch)
treeffab2b3458ebf52b64f8957504b3cd6cb2c7d89a
parentdev-perl/ExtUtils-XSpp: -r bump for EAPI7 (diff)
downloadgentoo-4e11438a.tar.gz
gentoo-4e11438a.tar.bz2
gentoo-4e11438a.zip
dev-haskell/hdbc: drop USE=test support, requres testpack
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-haskell/hdbc/hdbc-2.4.0.3.ebuild29
1 files changed, 3 insertions, 26 deletions
diff --git a/dev-haskell/hdbc/hdbc-2.4.0.3.ebuild b/dev-haskell/hdbc/hdbc-2.4.0.3.ebuild
index fb05e030b9da..90831462697a 100644
--- a/dev-haskell/hdbc/hdbc-2.4.0.3.ebuild
+++ b/dev-haskell/hdbc/hdbc-2.4.0.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,9 +19,9 @@ SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="2/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
+IUSE=""
-RESTRICT="test" # Requires dev-haskell/testpack (deprecated), and this is a problem.
+RESTRICT="test" # Requires unmaintaned dev-haskell/testpack
RDEPEND=">=dev-haskell/convertible-1.1.0.0:=[profile?]
dev-haskell/mtl:=[profile?]
@@ -30,32 +30,9 @@ RDEPEND=">=dev-haskell/convertible-1.1.0.0:=[profile?]
dev-haskell/text:=[profile?]
dev-haskell/utf8-string:=[profile?]
>=dev-lang/ghc-7.4.1:=
- test? ( dev-haskell/hunit:=[profile?]
- >=dev-haskell/quickcheck-2.0:2=[profile?]
- >=dev-haskell/testpack-2.0:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8
"
S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag test buildtests)
-}
-
-src_test() {
- # default tests
- haskell-cabal_src_test || die "cabal test failed"
-
- # built custom tests
- "${S}/dist/build/runtests/runtests" || die "unit tests failed"
-}
-
-src_install() {
- cabal_src_install
-
- # if tests were enabled, make sure the unit test driver is deleted
- rm -f "${ED}/usr/bin/runtests"
-}