summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjinqiang zhang <peeweep@0x0.ee>2023-04-11 17:54:25 +0800
committerSam James <sam@gentoo.org>2023-04-12 07:06:21 +0100
commit4e187139bebf47977bc329f0ad0d84041bc0cf37 (patch)
tree5c13d042bc51232688589845befecaae88d2f00f
parentdev-ruby/timers: backport test fixes (diff)
downloadgentoo-4e187139bebf47977bc329f0ad0d84041bc0cf37.tar.gz
gentoo-4e187139bebf47977bc329f0ad0d84041bc0cf37.tar.bz2
gentoo-4e187139bebf47977bc329f0ad0d84041bc0cf37.zip
dev-ruby/async-io: fix 1.34.3 tests
Closes: https://bugs.gentoo.org/904159 Signed-off-by: jinqiang zhang <peeweep@0x0.ee> Closes: https://github.com/gentoo/gentoo/pull/30552 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ruby/async-io/async-io-1.34.3-r1.ebuild4
-rw-r--r--dev-ruby/async-io/files/async-io-1.34.3-tests.patch19
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/async-io/async-io-1.34.3-r1.ebuild b/dev-ruby/async-io/async-io-1.34.3-r1.ebuild
index 2264c7d78b5c..68ba0af0f1c5 100644
--- a/dev-ruby/async-io/async-io-1.34.3-r1.ebuild
+++ b/dev-ruby/async-io/async-io-1.34.3-r1.ebuild
@@ -28,6 +28,10 @@ ruby_add_bdepend "test? (
dev-ruby/rack-test
)"
+PATCHES=(
+ "${FILESDIR}"/${P}-tests.patch
+)
+
all_ruby_prepare() {
sed -i -E 's/require_relative "(.+)"/require File.expand_path("\1")/g' "${RUBY_FAKEGEM_GEMSPEC}" || die
diff --git a/dev-ruby/async-io/files/async-io-1.34.3-tests.patch b/dev-ruby/async-io/files/async-io-1.34.3-tests.patch
new file mode 100644
index 000000000000..620405396dd1
--- /dev/null
+++ b/dev-ruby/async-io/files/async-io-1.34.3-tests.patch
@@ -0,0 +1,19 @@
+https://github.com/socketry/async-io/commit/fe6f1972c74ec0c5107e127cdb299f41b798e3dd
+https://bugs.gentoo.org/904159
+
+From fe6f1972c74ec0c5107e127cdb299f41b798e3dd Mon Sep 17 00:00:00 2001
+From: Samuel Williams <samuel.williams@oriontransfer.co.nz>
+Date: Sat, 18 Mar 2023 17:55:54 +1300
+Subject: [PATCH] Don't depend on status name.
+
+--- a/spec/async/io/notification_spec.rb
++++ b/spec/async/io/notification_spec.rb
+@@ -39,7 +39,7 @@
+ signalling_task.wait
+ waiting_task.wait
+
+- expect(waiting_task.status).to be :complete
++ expect(waiting_task).to be_complete
+
+ subject.close
+ end