summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2022-07-25 12:42:02 +0200
committerMatthew Smith <matthew@gentoo.org>2022-08-26 09:43:58 +0100
commit4e213d550a9cb24cb327585a9fa092652e494293 (patch)
tree0ada7644edb8faaffabb0dea314cb424d53d6de7
parentnet-misc/anydesk: take maintainership. (diff)
downloadgentoo-4e213d55.tar.gz
gentoo-4e213d55.tar.bz2
gentoo-4e213d55.zip
net-misc/anydesk: 6.2.0
The minizip requirement (but 829499) is no longer there for 6.2.0. Migration away from x11-libs/gtkglext (bug 698950) has happened. Dropped a few other dependencies too as I can't see how they are required with lddtree. We can consider the following changes still: 1. Removing the desktop and systemd units from files/ and using sed to update /usr/bin to /opt/bin instead. 2. Installing binary directly into /opt/bin rather than /opt/anydesk/ and then symlinking from /opt/bin. Bug: https://bugs.gentoo.org/705154 Closes: https://bugs.gentoo.org/829499 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Closes: https://github.com/gentoo/gentoo/pull/26587 Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--net-misc/anydesk/Manifest1
-rw-r--r--net-misc/anydesk/anydesk-6.2.0.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/net-misc/anydesk/Manifest b/net-misc/anydesk/Manifest
index 7610c2f5aa10..7cfe5d426f84 100644
--- a/net-misc/anydesk/Manifest
+++ b/net-misc/anydesk/Manifest
@@ -6,3 +6,4 @@ DIST anydesk-6.0.1-amd64.tar.gz 5209989 BLAKE2B 5588b40460af9033aca744440d5ce43d
DIST anydesk-6.0.1-i386.tar.gz 5130077 BLAKE2B 9d0467cb24493458efdac6d835b06ef22bb6db3aaeb7277386ae0749c215c3640e722e2e7d17964e32a668d63826a68f3429d3425fb7aabe59a2718648bd2b88 SHA512 58cf2ca8bb67f672ec2ac988216ab593479f09d32e8e6ace93b0d92640197f9d13a637480421be8b038f8840d91a89f97b937c9e3b3f115bc49a5fa852b2c064
DIST anydesk-6.1.0-amd64.tar.gz 5264850 BLAKE2B dd71ca67af11e84860f785a50bfb41a6fedae0f1cd28e9a9061d4f34a84a07add7900eb234ac77b0ffd6c2cb77b2e614e9b7d50b4f7045269c008070ab605064 SHA512 b58cd0bde8ef6bbf4878b276dc45297bdeb5c05c273d41b95465cbfec879b60c9295ae3a76e5cae4940ece5471c13856bb18b2785e0bea1866402afd95f5372a
DIST anydesk-6.1.1-amd64.tar.gz 5296860 BLAKE2B 676a5eddaa088a62f8f4ecb4b25ecce955331eaf4de383c1b029770e282bc79b45b600cbb7ad8c8918ff540b210e2a6bcee8330603c5bddaea821d794012c278 SHA512 435828660c44437441ab3f5c61783d29f772a958e6b465f24b880014faf120c51dc06a4c1da11bb383be99f9fc1f1f35994ea3a990fc0e94bc18fe26bf95958e
+DIST anydesk-6.2.0-amd64.tar.gz 6216311 BLAKE2B ffdd139e5e67cf9da5eefcd8c261a52d5e556923353baec8d848aea95a6583280845c3d2cf9c34fbcbecf9ddb3991aa59542baf74f2761cc4a7ee69637be0bd4 SHA512 673e5a0a0ca6d2c550c9c01a07edd2096db26416286a5a603adfc7a844d864f327061e0906978c6e4cd0871859f12f281a52b3bceffe8a6014a1bb3c54322ab6
diff --git a/net-misc/anydesk/anydesk-6.2.0.ebuild b/net-misc/anydesk/anydesk-6.2.0.ebuild
new file mode 100644
index 000000000000..60a3c0f9afd4
--- /dev/null
+++ b/net-misc/anydesk/anydesk-6.2.0.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit desktop optfeature systemd xdg-utils
+
+DESCRIPTION="Feature rich multi-platform remote desktop application"
+HOMEPAGE="https://anydesk.com"
+SRC_URI="https://download.anydesk.com/linux/${P}-amd64.tar.gz
+ https://download.anydesk.com/linux/generic-linux/${P}-amd64.tar.gz"
+
+# OpeSSL/SSLeay, libvpx, zlib, Xiph, xxHash
+LICENSE="AnyDesk-TOS BSD BSD-2 openssl ZLIB"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RDEPEND="
+ dev-libs/atk
+ dev-libs/glib:2
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ media-libs/glu
+ sys-auth/polkit
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/pango
+"
+BDEPEND="dev-util/patchelf"
+
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="opt/${PN}/*"
+
+src_install() {
+ local dst="/opt/${PN}"
+
+ exeinto ${dst}
+ doexe ${PN}
+
+ dodir /opt/bin
+ dosym "${dst}/${PN}" "/opt/bin/${PN}"
+
+ newinitd "${FILESDIR}/anydesk.init" anydesk
+ systemd_newunit "${FILESDIR}/anydesk-4.0.1.service" anydesk.service
+
+ insinto /usr/share/polkit-1/actions
+ doins polkit-1/com.anydesk.anydesk.policy
+
+ insinto /usr/share
+ doins -r icons
+
+ domenu "${FILESDIR}/anydesk.desktop"
+
+ dodoc copyright README
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To run AnyDesk as background service use:"
+ elog
+ elog "OpenRC:"
+ elog "# rc-service anydesk start"
+ elog "# rc-update add anydesk default"
+ elog
+ elog "Systemd:"
+ elog "# systemctl start anydesk.service"
+ elog "# systemctl enable anydesk.service"
+ elog
+ elog "Please see README at /usr/share/doc/${PF}/README.bz2 for"
+ elog "further information about the linux version of AnyDesk."
+ elog
+ fi
+
+ optfeature_header "AnyDesk uses additional tools to query information about the host:"
+ optfeature "lsb_release" sys-apps/lsb-release
+ optfeature "lspci" sys-apps/pciutils
+ optfeature "lsusb" sys-apps/usbutils
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}