summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2024-02-24 13:04:04 +0100
committerJakov Smolić <jsmolic@gentoo.org>2024-02-24 13:39:56 +0100
commit4e2eddf6d3a55c4e23808446d9268e8fff4b2851 (patch)
tree01735b6f7b1c247a37868e9663a12b671050f1eb
parentdev-build/bmake: drop 20231210 (diff)
downloadgentoo-4e2eddf6d3a55c4e23808446d9268e8fff4b2851.tar.gz
gentoo-4e2eddf6d3a55c4e23808446d9268e8fff4b2851.tar.bz2
gentoo-4e2eddf6d3a55c4e23808446d9268e8fff4b2851.zip
dev-libs/npth: add 1.7
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--dev-libs/npth/Manifest1
-rw-r--r--dev-libs/npth/npth-1.7.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/npth/Manifest b/dev-libs/npth/Manifest
index 3092cac1227f..528f8a186b80 100644
--- a/dev-libs/npth/Manifest
+++ b/dev-libs/npth/Manifest
@@ -1 +1,2 @@
DIST npth-1.6.tar.bz2 300486 BLAKE2B 665fdb2f4cbe59750b6b4b7c2701ee80a23a122df10c9f8be47c4af5f3bf5968f709637ab3f4878bb68609752fbb6ce1364e109fdfeba64e4db258733a33f3fc SHA512 2ed1012e14a9d10665420b9a23628be7e206fd9348111ec751349b93557ee69f1176bcf7e6b195b35b1c44a5e0e81ee33b713f03d79a33d1ecd9037035afeda2
+DIST npth-1.7.tar.bz2 313213 BLAKE2B 39bc5857fb61a4264bef6ff23c28755d2a3b3ceef93034aefd5cf1c2ad905adf696c6753ebd5cea5e0a875df4ecb97db03e023a50a27f51ec0641bbc36b54089 SHA512 8893023bcf953a3f7c490cf8116bed323a9d4af2bea35277e919f437916fda8b8e68ded28ec1777717cf9187c504892556159cbdb8bc02ed4a8b30b3d897d244
diff --git a/dev-libs/npth/npth-1.7.ebuild b/dev-libs/npth/npth-1.7.ebuild
new file mode 100644
index 000000000000..71d952cdae8c
--- /dev/null
+++ b/dev-libs/npth/npth-1.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="New GNU Portable Threads Library"
+HOMEPAGE="https://git.gnupg.org/cgi-bin/gitweb.cgi?p=npth.git"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
+ econf $(use_enable test tests)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}