summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-16 13:15:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-16 14:45:35 +0200
commit4e303c27a6ff24a8042a869538d1f26ea3d46231 (patch)
tree7fb040ce7f0d8e0b75f610d2f09ade161d8ccacb
parentdev-python/a2wsgi: Add missing dev-python/pytest-asyncio dep (diff)
downloadgentoo-4e303c27a6ff24a8042a869538d1f26ea3d46231.tar.gz
gentoo-4e303c27a6ff24a8042a869538d1f26ea3d46231.tar.bz2
gentoo-4e303c27a6ff24a8042a869538d1f26ea3d46231.zip
dev-qt/qtlocation: Fix build with >=dev-libs/icu-75
Bumping to MAPBOXGL_COMMIT=35d566724c48180c9a372c2ed50a253871a51574 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.13-r1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index f0042c44d64e..0604f733b4e1 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1,4 +1,5 @@
DIST qtlocation-5.15.11-patchset.tar.xz 4796 BLAKE2B dcfa75bd3fb2e9069e1a530c27e2b4e9ac921fcf0ccb712f0894375b575ba25103948c6e5b85b56a8f9c9f2d7edf7df8e38501e93356e69f060b577a04c2d221 SHA512 14bd2864abc6f446dc4fbac03548cb42305685b46db757d856360780144095a021130bc0ebf1d07a516dc7991dc0cfbf733bd0ef6be58237bc15822c21af1d0b
DIST qtlocation-everywhere-opensource-src-5.15.13.tar.xz 6554724 BLAKE2B 26cc97cc210a4c2afcd5ca57f849081772f8e65f2fb809424f257f6e24309a702483be73085825f63ac283705db8e967b96132dac710cfaa0759c882802aad60 SHA512 37ccec9d9ce4ab59c0e4a2827c94d2e7247786fa53dc340539160631aaa9e5de02fbff1a5fadc5d96c64b2d9a81a5912a562beb6e4d0ec09186f8508626ade36
DIST qtlocation-everywhere-src-6.7.0.tar.xz 3165588 BLAKE2B ee2f3be403942d91f1a87e89d42d1f969eefc90654c77732d7249766e680ce1cb63685203989ceef984365ff59152995e6886bf5f112834d55abf0e6239229ae SHA512 51e3777cdee6c27bf5770dfa4f21509ab4699161b5b49d99696aa09018ee5a355c921a85f8f1a732a80b19730ac30d40795d20cd73e4aefc1a4d4a989d41bc3d
+DIST qtlocation-mapboxgl-5.15.13-35d56672.tar.gz 3726302 BLAKE2B f51c0589a06fab35ba85b3bf4ca8a1904cda5aec47b17fdf747da527d02be623a76b1af5883b33267fab825a4b5d0863ea0220f2907e98e286b40d4a0bbc82e5 SHA512 5c2ff6ab7e4382d87546a802c5603bdcec3deb7fbb836fc981292c67660514caaa6118e164d2e099d0304710035572706562ec84e4aba5ce36b01cade8b0993e
DIST qtlocation-mapboxgl-5.15.13-4c88f2c0.tar.gz 3726387 BLAKE2B e9b818505ace86516262d1407450c14be82122bb91363a57708795844089371ac7d511a857f713c7cb4e6f8b54867aab0bc5dcdb9c49aa28aa3f8363271378e0 SHA512 e4d9133db892fd8b7b1bcf584bf7dae30c0f0353f3b0a696a6cabc9485067f262d42554b583640521734498572e5480b5e8d0143d5be47bb92077f3192fefa4d
diff --git a/dev-qt/qtlocation/qtlocation-5.15.13-r1.ebuild b/dev-qt/qtlocation/qtlocation-5.15.13-r1.ebuild
new file mode 100644
index 000000000000..3a3718d72c58
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.15.13-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PATCHSET="${PN}-5.15.11-patchset"
+inherit qt5-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ MAPBOXGL_COMMIT=35d566724c48180c9a372c2ed50a253871a51574
+ SRC_URI+=" https://invent.kde.org/qt/qt/${PN}-mapboxgl/-/archive/${MAPBOXGL_COMMIT}/${PN}-mapboxgl-${MAPBOXGL_COMMIT}.tar.gz -> ${PN}-mapboxgl-${PV}-${MAPBOXGL_COMMIT:0:8}.tar.gz
+ https://dev.gentoo.org/~asturm/distfiles/${PATCHSET}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+RDEPEND="
+ dev-libs/icu:=
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtdeclarative-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ =dev-qt/qtpositioning-${QT5_PV}*[qml]
+ =dev-qt/qtsql-${QT5_PV}*
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ =dev-qt/qtconcurrent-${QT5_PV}*
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/imports/locationlabs
+ src/plugins/geoservices
+)
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+
+PATCHES=( "${WORKDIR}/${PATCHSET}" )
+
+src_prepare() {
+ rm -rf src/3rdparty/mapbox-gl-native/* || die
+ mv "${WORKDIR}"/${PN}-mapboxgl-${MAPBOXGL_COMMIT}/* src/3rdparty/mapbox-gl-native || die
+ qt5-build_src_prepare
+}
+fi
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ qt5_configure_oos_quirk qtlocation-config.pri src/location
+ qt5-build_src_configure
+}