summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-02 17:30:16 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-02 18:17:06 +0300
commit4e446d13fe820ffe83d4819e5d0ee38191c9741d (patch)
tree66883660cc2f3f1e7ea885351314be480406439b
parentdev-libs/protobuf: add 3.20.1 (diff)
downloadgentoo-4e446d13.tar.gz
gentoo-4e446d13.tar.bz2
gentoo-4e446d13.zip
dev-python/protobuf-python: add 3.20.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/protobuf-python/Manifest1
-rw-r--r--dev-python/protobuf-python/protobuf-python-3.20.1.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/protobuf-python/Manifest b/dev-python/protobuf-python/Manifest
index 445bb0b6652e..dfb0564c5120 100644
--- a/dev-python/protobuf-python/Manifest
+++ b/dev-python/protobuf-python/Manifest
@@ -1 +1,2 @@
DIST protobuf-3.19.3.tar.gz 5293258 BLAKE2B c05b70ffca97f7166ea6a511a36907eed125edf1ebf17f908718221d9b851be84dfb2b1b39973f2faf35f6ade630e6ba4f9e8b91b8fbc922c5db97079323ee6e SHA512 1c003e7cbc8eae6a038f46e688b401ee202ba47f502561e909df79770f6e8b7daf3dc1ccc727e31bfb5b52cd04cb4fef7d2d2a28d650c13f396872ad4aa076c6
+DIST protobuf-3.20.1.tar.gz 5368262 BLAKE2B 1ce1aef2e4c4f3ea4863629cc75d89fe17d0c7ac0c342ac641c787456fd4a12756c2892a27ddadedc94a7201494ec84566638ce33a03cb0c867b04e9eee0edb3 SHA512 fde3eb9f13946887ddfd87df428c5615ad09aaf191e4478b24e98e5e13231feeff4e70b4ca6a2ff7d9b9b2e2c60bc1d5479526edeafa78f9a8ed3bef2e0bacb0
diff --git a/dev-python/protobuf-python/protobuf-python-3.20.1.ebuild b/dev-python/protobuf-python/protobuf-python-3.20.1.ebuild
new file mode 100644
index 000000000000..72300c2997d3
--- /dev/null
+++ b/dev-python/protobuf-python/protobuf-python-3.20.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2008-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/protocolbuffers/protobuf"
+ EGIT_SUBMODULES=()
+fi
+
+DESCRIPTION="Google's Protocol Buffers - Python bindings"
+HOMEPAGE="
+ https://developers.google.com/protocol-buffers/
+ https://github.com/protocolbuffers/protobuf/
+ https://pypi.org/project/protobuf/
+"
+if [[ "${PV}" != "9999" ]]; then
+ SRC_URI="
+ https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz
+ -> protobuf-${PV}.tar.gz
+ "
+fi
+S="${WORKDIR}/protobuf-${PV}/python"
+
+LICENSE="BSD"
+SLOT="0/30"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ ~dev-libs/protobuf-${PV}
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${PYTHON_DEPS}
+ ~dev-libs/protobuf-${PV}
+"
+RDEPEND="
+ ${BDEPEND}
+ !dev-python/namespace-google
+"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_CHECKOUT_DIR="${WORKDIR}/protobuf-${PV}"
+fi
+
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ pushd "${WORKDIR}/protobuf-${PV}" > /dev/null || die
+ eapply_user
+ popd > /dev/null || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ DISTUTILS_ARGS=(--cpp_implementation)
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}/install" -name "*.pth" -type f -delete || die
+}