summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-28 20:37:52 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-28 20:48:40 +0200
commit4e4b98e70a7d7c3ee58b1887e13492c3d1cf0f61 (patch)
tree0c9aa42ede213275f906b78d23ee632f1ef14cd2
parentdev-python/flask: Remove the live ebuild (diff)
downloadgentoo-4e4b98e70a7d7c3ee58b1887e13492c3d1cf0f61.tar.gz
gentoo-4e4b98e70a7d7c3ee58b1887e13492c3d1cf0f61.tar.bz2
gentoo-4e4b98e70a7d7c3ee58b1887e13492c3d1cf0f61.zip
dev-python/werkzeug: Bump to 2.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/werkzeug/Manifest1
-rw-r--r--dev-python/werkzeug/werkzeug-2.1.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/werkzeug/Manifest b/dev-python/werkzeug/Manifest
index 9d25ab90f0cd..0d9dbfd332f9 100644
--- a/dev-python/werkzeug/Manifest
+++ b/dev-python/werkzeug/Manifest
@@ -2,3 +2,4 @@ DIST werkzeug-1.0.1.gh.tar.gz 907482 BLAKE2B d2dcdce8b1bcbb177b52b0915f2c0ac17d2
DIST werkzeug-2.0.3.gh.tar.gz 897523 BLAKE2B 1f97a2f7184e8e11bb85722becae7cc032ada38a642a2f925f7b81e89c881011889189999d50dab4591fc2e874aac4ab92b0f1531c211468cf352e31b0b8c8d0 SHA512 a205cd981b3e1b481436e483190427ff3808a5ea80abc616ca08d899d0e6a39893a5cb60adc65c99dcab3af47c24b321c71996d719cb7f224de7942b44b1fd69
DIST werkzeug-2.1.0.gh.tar.gz 833188 BLAKE2B eed6ddc3acec9a69ca983d440d14693750fc0d09cd1f30f66e27267c266ac5a2c81b21cb8d617e8f6fcfb7426bb427c2dc1cafeec92a238424a005d915dffc4f SHA512 acda1e4037e1d525cbd82ed2310ddf55968d14df6656018b910d7200b51569e88cf58957f94f377deb7fe100db03d30016e9dc91e033a298ad54cb34922be30e
DIST werkzeug-2.1.1.gh.tar.gz 833268 BLAKE2B 28d922f99259b606c431b224222fe6474c68f8a11f9910fe9e4eedbdf30d18a101c25490dee205035ea7b3675e644f619a81cbf493c7d5540c6141ff3840d84a SHA512 992b5b0a95db5266d025e06683b04f932def72c3967b2c9903f718c5f2672cf0abadb247cf77029d99b567c9588f5ae03b6b07d566bfd764c738ede53501ba1b
+DIST werkzeug-2.1.2.gh.tar.gz 833667 BLAKE2B e045f566862bfe0f86185cd10aa26bf94a4fc2f7b23173c6a28c9b55d0f239fbba5c66071fab5df6102717b51a1c1fada872e9d9383b9d3b34ab92ffcfd96e59 SHA512 28c4a794a3dbc8423e59244fbcf192b60b53f378444aaaf60330bdd62cec38a4625033b5d72b55613c8b26053a60153ddcb816331ff28ad3ee03bede74d8b1b3
diff --git a/dev-python/werkzeug/werkzeug-2.1.2.ebuild b/dev-python/werkzeug/werkzeug-2.1.2.ebuild
new file mode 100644
index 000000000000..a67e3c314151
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-2.1.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="
+ https://palletsprojects.com/p/werkzeug/
+ https://pypi.org/project/Werkzeug/
+ https://github.com/pallets/werkzeug/
+"
+SRC_URI="
+ https://github.com/pallets/werkzeug/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/ephemeral-port-reserve[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ !alpha? ( !hppa? ( !ia64? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ ) ) )
+ !hppa? ( !ia64? (
+ $(python_gen_cond_dep '
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ ' 'python*')
+ ) )
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ "tests/test_serving.py::test_server[https]"
+ tests/test_serving.py::test_ssl_dev_cert
+ tests/test_serving.py::test_ssl_object
+ )
+ fi
+
+ # the default portage tempdir is too long for AF_UNIX sockets
+ local -x TMPDIR=/tmp
+ epytest -p no:django -p no:httpbin tests
+}