summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-20 09:55:38 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-20 09:55:38 +0300
commit4e4e6abf7e75aac984341cacf3426862ff6ec689 (patch)
tree9e5b10c2665ed083b16fe6cc3ccd565309ee0a52
parentdev-lang/python: Revert "stable 3.10.0_rc1_p2 for sparc, ..." (diff)
downloadgentoo-4e4e6abf.tar.gz
gentoo-4e4e6abf.tar.bz2
gentoo-4e4e6abf.zip
sci-libs/shapely: enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--sci-libs/shapely/shapely-1.7.1-r1.ebuild28
1 files changed, 9 insertions, 19 deletions
diff --git a/sci-libs/shapely/shapely-1.7.1-r1.ebuild b/sci-libs/shapely/shapely-1.7.1-r1.ebuild
index 7c75f9f5be29..749e53b1ac3e 100644
--- a/sci-libs/shapely/shapely-1.7.1-r1.ebuild
+++ b/sci-libs/shapely/shapely-1.7.1-r1.ebuild
@@ -3,39 +3,29 @@
EAPI=7
-MY_PN="Shapely"
-MY_P="${MY_PN}-${PV}"
-
-PYTHON_COMPAT=( python3_{7..9} )
-
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Geometric objects, predicates, and operations"
HOMEPAGE="https://pypi.org/project/Shapely/ https://github.com/Toblerity/Shapely"
SRC_URI="https://github.com/Toblerity/Shapely/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P^}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm64 x86"
-RDEPEND="
+DEPEND=">=sci-libs/geos-3.9"
+RDEPEND="${DEPEND}
dev-python/numpy[${PYTHON_USEDEP}]
- >=sci-libs/geos-3.9
"
-
-BDEPEND="${RDEPEND}
+BDEPEND="${DEPEND}
dev-python/cython[${PYTHON_USEDEP}]
"
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=( "${FILESDIR}/${P}-tests-support-geos-3.9.patch" )
-
-distutils_enable_tests pytest
+PATCHES=(
+ "${FILESDIR}/${P}-tests-support-geos-3.9.patch"
+)
+distutils_enable_tests --install pytest
distutils_enable_sphinx docs dev-python/matplotlib
-
-python_test() {
- distutils_install_for_testing
- ${EPYTHON} -m pytest tests || die "tests failed under ${EPYTHON}"
-}