summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-08 21:58:14 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-08 22:03:47 +0100
commit4e60710a9dc75a7cfb2f34d6a22c93ec51396477 (patch)
treea1f838ffdd68de947772fa9f50170aa3ce7afc8d
parentpackage.mask: Rescue dev-python/python-discid (diff)
downloadgentoo-4e60710a9dc75a7cfb2f34d6a22c93ec51396477.tar.gz
gentoo-4e60710a9dc75a7cfb2f34d6a22c93ec51396477.tar.bz2
gentoo-4e60710a9dc75a7cfb2f34d6a22c93ec51396477.zip
dev-python/python-discid: Bump to 1.2.0, py3.[78]
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-discid/Manifest1
-rw-r--r--dev-python/python-discid/python-discid-1.2.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-discid/Manifest b/dev-python/python-discid/Manifest
index a03d1a5a2791..69df8f877893 100644
--- a/dev-python/python-discid/Manifest
+++ b/dev-python/python-discid/Manifest
@@ -1 +1,2 @@
DIST python-discid-1.1.1.tar.gz 30454 BLAKE2B 4ddf680ef824498ce1db318718b1f55067538a6f1e772df2c83b2cf6c9e75ba2b068587d447307a771dee6fe20725d64309e78b2afadfdbf8f6a8673dc30616e SHA512 b040137162a2588c653f390a4d0b549b322bb4e2745a3738c1ba72a1984722358fc85a306f4cd5d41c1e599e40d01c6e2b08d67951a820c2d1116d96eb618c8e
+DIST python-discid-1.2.0.tar.gz 30756 BLAKE2B 616613de23b66adfc92227a9f36b710649f2a419ffd83443766ebcf1dbfaf528b7d933011bcbdcd19f5092726b81e40d905a62a64262a528dfad89e561210992 SHA512 239cb608508e94109aa9b8b582bc3de1fb9408b508d56698d7f17ec9ebb0d37c1fb76557d98b6d194c1532e3047efcde3adc5d6e9634bc87533d331423a7f19f
diff --git a/dev-python/python-discid/python-discid-1.2.0.ebuild b/dev-python/python-discid/python-discid-1.2.0.ebuild
new file mode 100644
index 000000000000..7e4e0450c284
--- /dev/null
+++ b/dev-python/python-discid/python-discid-1.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libdiscid"
+HOMEPAGE="https://github.com/JonnyJD/python-discid"
+SRC_URI="https://github.com/JonnyJD/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=media-libs/libdiscid-0.2.2"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx doc
+
+python_test() {
+ esetup.py test
+}