summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-30 19:37:56 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-30 20:09:38 +0300
commit4e73a9509adc0bce3fd5779057c5ee057f82814a (patch)
tree2c73893dd866302e71b6aee9a3a114d51bc65ed3
parentselinux-policy-2.eclass: update copyright year (diff)
downloadgentoo-4e73a950.tar.gz
gentoo-4e73a950.tar.bz2
gentoo-4e73a950.zip
dev-python/mako: add 1.2.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/mako/Manifest1
-rw-r--r--dev-python/mako/mako-1.2.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/mako/Manifest b/dev-python/mako/Manifest
index ecd482abd751..10beb76db047 100644
--- a/dev-python/mako/Manifest
+++ b/dev-python/mako/Manifest
@@ -1 +1,2 @@
DIST Mako-1.2.0.tar.gz 488603 BLAKE2B 30ef597e2dd500d52d02118e0ec8a40cfeeff00604eb9fec887df4aff794aed7d6a1d78b2defb6f985947f9429d912a083b9941ee30b1e53ef32890d19e94158 SHA512 ad608016d7785a735a28ea18f697be4882da747e3da32e4a7c7be4bf846d37e4d3374d78e62ef85607ae9f3f73ee35dc78b473347e4110c059a504be2c497c6e
+DIST Mako-1.2.1.tar.gz 489560 BLAKE2B c8006d5f7a814a1466ad6643200693f014c4a23f284701a9bea6a27246c196c87e5c4bf8e12ae0525563ce60c93944a58b1fa45afc6caf3362aa1d761148910a SHA512 02393054c9e3857ee412f494b01d702b5f367165d2f57a5ff9df34ba1a042b60c7b6c059ce2c53bcb91e3a4a21179eca884ee051bf5f5f3522c05253088d38a5
diff --git a/dev-python/mako/mako-1.2.1.ebuild b/dev-python/mako/mako-1.2.1.ebuild
new file mode 100644
index 000000000000..113cd08e2976
--- /dev/null
+++ b/dev-python/mako/mako-1.2.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P^}
+DESCRIPTION="A Python templating language"
+HOMEPAGE="
+ https://www.makotemplates.org/
+ https://github.com/sqlalchemy/mako/
+ https://pypi.org/project/Mako/
+"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/markupsafe-0.9.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/Babel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # change in pygments
+ test/test_exceptions.py::ExceptionsTest::test_format_exceptions_pygments
+ )
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ test/test_exceptions.py::ExceptionsTest::test_alternating_file_names
+ )
+ local EPYTEST_IGNORE=(
+ # lingua is not packaged in Gentoo and the skip is currently broken
+ # https://github.com/sqlalchemy/mako/pull/357
+ test/ext/test_linguaplugin.py
+ )
+ epytest
+}
+
+python_install_all() {
+ rm -r doc/build || die
+
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}