summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-09-04 20:13:30 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-09-04 20:38:15 +0200
commit4e7b026f12b50736473198852da90f6235a64d60 (patch)
tree38fdfa75e09b8ad57b5eabb985010115c964ddee
parentxfce-base/xfce4-panel: Stabilize 4.16.5 ppc64, #868426 (diff)
downloadgentoo-4e7b026f12b50736473198852da90f6235a64d60.tar.gz
gentoo-4e7b026f12b50736473198852da90f6235a64d60.tar.bz2
gentoo-4e7b026f12b50736473198852da90f6235a64d60.zip
app-arch/bzip3: bump to 1.1.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-arch/bzip3/Manifest1
-rw-r--r--app-arch/bzip3/bzip3-1.1.5.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-arch/bzip3/Manifest b/app-arch/bzip3/Manifest
index 1401a12d0b3d..1d58b429b010 100644
--- a/app-arch/bzip3/Manifest
+++ b/app-arch/bzip3/Manifest
@@ -1,3 +1,4 @@
DIST bzip3-1.1.2.tar.xz 256108 BLAKE2B a5f91fe2760fd4f7f79b908d735d613823dedac23e59950317c26f50d0a657dde042e5a08d401984c14d686d33726caa81e4b34cbca26e28c57a96f61e4f23ab SHA512 8b179bfe9b1b67c516580934cd12a640c86b3f9525c5e7902672051d80198cb91aa8880a4ca3ce14a879d26873405c713f1a0c6a33138d21f4d51c9e93d8fac5
DIST bzip3-1.1.3.tar.xz 257212 BLAKE2B cc94b4c2caa3123b2c775d66143757bcaea7ead6d8a130391d6714583cfcb92fffca47ad80ffc8b5a01483f6cbfab7101c96521cd97e740116c9e10c64c358e8 SHA512 d48695d066ddc79e81c189f8c06e999f8eb8191982db8908f7bd4dfaa0f8fab1ba57e41664962cc6e8611f8398603918e4bd4d58efff2f04292ea54983a6f38d
DIST bzip3-1.1.4.tar.xz 260404 BLAKE2B ddd087b631c9d5945dea0f4da280dfd74fd303eaed10f7553f770ca18b3b65f00718c073d87e565602a9ed02f4604a0d2dda0ff42cbd38f593bb012f5362cc5c SHA512 86f26b290001d255ad1d2378b5e2d59f9c85e1625ba5d7dca86acd544bb80af95b3379c215a03e0f81f77b7972a852d37746c1028464f404d28a6f9b707383b8
+DIST bzip3-1.1.5.tar.xz 265340 BLAKE2B 0226a97d564f1c9d9d1089b43ae79a9e43d0b77628298ef953c45505ad8d62caaf17bf6fa357857f123cf072b8ccd3003bfe138f25284baa5a5a5cdd8a555f71 SHA512 589c2e8e675a61014c7c4e82d0f2067201e3fb97bf7cfa6b7aa23690dc739824226089ac710509cc085b22eeb671ed5e23c6493967a433d3b284cb638af71be8
diff --git a/app-arch/bzip3/bzip3-1.1.5.ebuild b/app-arch/bzip3/bzip3-1.1.5.ebuild
new file mode 100644
index 000000000000..0d9329da48ca
--- /dev/null
+++ b/app-arch/bzip3/bzip3-1.1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A better and stronger spiritual successor to BZip2"
+HOMEPAGE="https://github.com/kspalaiologos/bzip3"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kspalaiologos/${PN}.git"
+else
+ SRC_URI="https://github.com/kspalaiologos/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0"
+
+src_configure() {
+ # ./configure script will default to Clang if it is found on the system,
+ # force the use of CC selected by the user with CC=$(tc-getCC)
+ econf CC=$(tc-getCC)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}