summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-08-13 17:03:57 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-08-13 17:14:25 +0200
commit4e95f88699b07e768974f9e5bb30bfe6735e8fcc (patch)
tree303b25cfd9cc72599980ae9067b82d3414d58608
parentwww-servers/apache: fix dependencies for mod_proxy_http2 (diff)
downloadgentoo-4e95f886.tar.gz
gentoo-4e95f886.tar.bz2
gentoo-4e95f886.zip
www-servers/apache: add mod_auth_form support
Closes: https://bugs.gentoo.org/438084 Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--profiles/desc/apache2_modules.desc5
-rw-r--r--www-servers/apache/apache-2.4.41.ebuild19
2 files changed, 19 insertions, 5 deletions
diff --git a/profiles/desc/apache2_modules.desc b/profiles/desc/apache2_modules.desc
index a414540a3cf0..8f6258033d4c 100644
--- a/profiles/desc/apache2_modules.desc
+++ b/profiles/desc/apache2_modules.desc
@@ -10,6 +10,7 @@ alias - Provides for mapping different parts of the host filesystem in the docum
asis - Sends files that contain their own HTTP headers
auth_basic - Basic authentication
auth_digest - User authentication using MD5 Digest Authentication
+auth_form - Allows the use of an HTML login form to restrict access by looking up users in the given providers
authn_alias - Provides the ability to create extended authentication providers based on actual providers
authn_anon - Allows "anonymous" user access to authenticated areas
authn_core - Provides core authentication capabilities common to all authentication providers (functionality provided by authn_alias in previous versions)
@@ -81,6 +82,10 @@ ratelimit - Bandwidth Rate Limiting for Clients
remoteip - Replaces the original client IP address for the connection with the useragent IP address list presented by a proxies or a load balancer via the request headers
reqtimeout - Set timeout and minimum data rate for receiving requests
rewrite - Provides a rule-based rewriting engine to rewrite requested URLs on the fly
+session - Provides support for a server wide per user session interface
+session_crypto - Provides support for the encryption of user sessions before being written to a local database, or written to a remote browser via an HTTP cookie
+session_cookie - Provides support for the storage of user sessions on the remote browser within HTTP cookies
+session_dbd - Provides support for the storage of user sessions within a SQL database using the mod_dbd module
setenvif - Allows the setting of environment variables based on characteristics of the request
slotmem_shm - Slot-based shared memory provider
socache_shmcb - A shared object cache provider using a high-performance cyclic buffer inside a shared memory segment
diff --git a/www-servers/apache/apache-2.4.41.ebuild b/www-servers/apache/apache-2.4.41.ebuild
index f7bdde5774ee..a74cf4c81e16 100644
--- a/www-servers/apache/apache-2.4.41.ebuild
+++ b/www-servers/apache/apache-2.4.41.ebuild
@@ -30,7 +30,7 @@ IUSE_MPMS_THREAD="event worker"
# slotmem_shm: Slot-based shared memory provider (for lbmethod_byrequests).
# socache_shmcb: shared object cache provider. Default config with ssl needs it
# unixd: fixes startup error: Invalid command 'User'
-IUSE_MODULES="access_compat actions alias asis auth_basic auth_digest
+IUSE_MODULES="access_compat actions alias asis auth_basic auth_digest auth_form
authn_alias authn_anon authn_core authn_dbd authn_dbm authn_file authz_core
authz_dbd authz_dbm authz_groupfile authz_host authz_owner authz_user autoindex
brotli cache cache_disk cache_socache cern_meta charset_lite cgi cgid dav dav_fs dav_lock
@@ -38,9 +38,10 @@ dbd deflate dir dumpio env expires ext_filter file_cache filter headers http2
ident imagemap include info lbmethod_byrequests lbmethod_bytraffic lbmethod_bybusyness
lbmethod_heartbeat log_config log_forensic logio macro md mime mime_magic negotiation
proxy proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_html proxy_http proxy_scgi
-proxy_http2 proxy_fcgi proxy_wstunnel rewrite ratelimit remoteip reqtimeout setenvif
-slotmem_shm speling socache_shmcb status substitute unique_id userdir usertrack
-unixd version vhost_alias watchdog xml2enc"
+proxy_http2 proxy_fcgi proxy_wstunnel rewrite ratelimit remoteip reqtimeout
+session session_cookie session_crypto session_dbd setenvif slotmem_shm speling
+socache_shmcb status substitute unique_id userdir usertrack unixd version vhost_alias
+watchdog xml2enc"
# The following are also in the source as of this version, but are not available
# for user selection:
# bucketeer case_filter case_filter_in echo http isapi optional_fn_export
@@ -49,6 +50,7 @@ unixd version vhost_alias watchdog xml2enc"
# inter-module dependencies
# TODO: this may still be incomplete
MODULE_DEPENDS="
+ auth_form:session
brotli:filter
dav_fs:dav
dav_lock:dav
@@ -79,6 +81,9 @@ MODULE_DEPENDS="
proxy_scgi:proxy
proxy_fcgi:proxy
proxy_wstunnel:proxy
+ session_cookie:session
+ session_dbd:dbd
+ session_dbd:session
substitute:filter
"
@@ -142,7 +147,11 @@ IUSE="${IUSE} +suexec-caps suexec-syslog"
CDEPEND="apache2_modules_brotli? ( >=app-arch/brotli-0.6.0:= )
apache2_modules_http2? ( >=net-libs/nghttp2-1.2.1 )
apache2_modules_proxy_http2? ( >=net-libs/nghttp2-1.2.1 )
- apache2_modules_md? ( >=dev-libs/jansson-2.10 )"
+ apache2_modules_md? ( >=dev-libs/jansson-2.10 )
+ apache2_modules_session_crypto? (
+ libressl? ( dev-libs/apr-util[libressl] )
+ !libressl? ( dev-libs/apr-util[openssl] )
+ )"
DEPEND+="${CDEPEND}
suexec? ( suexec-caps? ( sys-libs/libcap ) )"