summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-08 07:14:49 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-08 07:55:42 +0200
commit4ea560193c9611e8e3e13297577a2614bf4b984a (patch)
treef5267ff23bca6d50108422e2b63b31801d7eaa97
parentmedia-sound/qtractor: bump to 0.9.34 (diff)
downloadgentoo-4ea560193c9611e8e3e13297577a2614bf4b984a.tar.gz
gentoo-4ea560193c9611e8e3e13297577a2614bf4b984a.tar.bz2
gentoo-4ea560193c9611e8e3e13297577a2614bf4b984a.zip
dev-python/starlette: Bump to 0.28.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/starlette/Manifest1
-rw-r--r--dev-python/starlette/starlette-0.28.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/starlette/Manifest b/dev-python/starlette/Manifest
index 134c928cf500..b8de93031c98 100644
--- a/dev-python/starlette/Manifest
+++ b/dev-python/starlette/Manifest
@@ -1 +1,2 @@
DIST starlette-0.27.0.gh.tar.gz 2838346 BLAKE2B 25f30e83edc12fa6607ef31b2711ee2b3c205aa62cc362d4a7389d61e48fc4410610841caca2e99dd3527eb0f47fe2740c5908ab5c72158e57a384563b53328d SHA512 dd7ce57b78a5ab42e62699e6feed735c66aa64dce2004304a139957c75192cc0b3a475e80bb9ecee16093940d45f142f83e61af6fad0f320a8f586fea752049f
+DIST starlette-0.28.0.gh.tar.gz 2843094 BLAKE2B a3cb35cf465b4540457cffafe4a3bb32081f542b8a5c730bc7fcc0bbf9f7a6c2c21bcc4297c8f3c5281f6ca787aa03c3ee4f90032155d1aa1887440dc289e5c1 SHA512 344c0581e6d6e64abd51347757cba4eb9bfba6f66bf62a2a5491cd3bb1c332895d6827bc478c00d9dfe3043152e814b6870894577a4e9547ac116c66f75a49b1
diff --git a/dev-python/starlette/starlette-0.28.0.ebuild b/dev-python/starlette/starlette-0.28.0.ebuild
new file mode 100644
index 000000000000..11703340a66f
--- /dev/null
+++ b/dev-python/starlette/starlette-0.28.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="The little ASGI framework that shines"
+HOMEPAGE="
+ https://www.starlette.io/
+ https://github.com/encode/starlette/
+ https://pypi.org/project/starlette/
+"
+# no docs or tests in sdist, as of 0.27.0
+SRC_URI="
+ https://github.com/encode/starlette/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/python-multipart[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-3.10.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ test? (
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Unpackaged 'databases' dependency
+ tests/test_database.py
+)
+
+distutils_enable_tests pytest