summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2023-08-21 20:44:53 -0400
committerRick Farina <zerochaos@gentoo.org>2023-08-21 20:44:53 -0400
commit4ea5f19ddebee6c08ce4f69e92aadcd6305e5947 (patch)
treecb275e4b0677665f1a6c943ccd2ea489e061aaa9
parentmedia-radio/chirp: add deps for rr (diff)
downloadgentoo-4ea5f19ddebee6c08ce4f69e92aadcd6305e5947.tar.gz
gentoo-4ea5f19ddebee6c08ce4f69e92aadcd6305e5947.tar.bz2
gentoo-4ea5f19ddebee6c08ce4f69e92aadcd6305e5947.zip
app-misc/no-more-secrets: add 1.0.1
Also add sneakers binary Closes: https://bugs.gentoo.org/866335 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
-rw-r--r--app-misc/no-more-secrets/Manifest1
-rw-r--r--app-misc/no-more-secrets/no-more-secrets-1.0.1.ebuild30
-rw-r--r--app-misc/no-more-secrets/no-more-secrets-9999.ebuild11
3 files changed, 37 insertions, 5 deletions
diff --git a/app-misc/no-more-secrets/Manifest b/app-misc/no-more-secrets/Manifest
index 7806d7d107b8..7b017c318ea2 100644
--- a/app-misc/no-more-secrets/Manifest
+++ b/app-misc/no-more-secrets/Manifest
@@ -1 +1,2 @@
DIST no-more-secrets-0.3.3.tar.gz 24713 BLAKE2B c47cc71e72c8bc10bfc27b382e22d1b808b1efa65f3355ce0b435490c1628e476824414541fd12c58c99b47822724bb8cb6cdf1a0b0edf05068e7400cfcef09a SHA512 d261c9d2f7617149815627a4b6817aa5b483045cefbad148038ac9f13bc231b571034791aaaabc2ce9ab112cecc6015efc74167955099b8b57d1810f81210b31
+DIST no-more-secrets-1.0.1.tar.gz 25251 BLAKE2B 6508c65281c36effff7ccba80ad47b76c0f6c509bb4aeb4ffb35adef0b25612991e9923737128c1581a28b20bf2338cef7315b60ed8a637ea9b499d390193299 SHA512 436f092af23252d043f9b790f2e92fdfe0316fb07da66d7c35eda3967aeeab48a402ee6ca8b3630677798f74846f375ca071d828d0d5493f58418366dfc3366f
diff --git a/app-misc/no-more-secrets/no-more-secrets-1.0.1.ebuild b/app-misc/no-more-secrets/no-more-secrets-1.0.1.ebuild
new file mode 100644
index 000000000000..54a201cd898d
--- /dev/null
+++ b/app-misc/no-more-secrets/no-more-secrets-1.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/bartobri/no-more-secrets.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/bartobri/no-more-secrets/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+DESCRIPTION="Recreate decrypting text from 1992 movie 'Sneakers'"
+HOMEPAGE="https://github.com/bartobri/no-more-secrets"
+
+LICENSE="GPL-3"
+SLOT=0
+
+BDEPEND=""
+DEPEND="sys-libs/ncurses:0="
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/no-more-secrets-9999-2018-10-25-respect-ldflags.patch )
+
+src_compile() {
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" emake all
+}
diff --git a/app-misc/no-more-secrets/no-more-secrets-9999.ebuild b/app-misc/no-more-secrets/no-more-secrets-9999.ebuild
index 6fcda186cfdf..54a201cd898d 100644
--- a/app-misc/no-more-secrets/no-more-secrets-9999.ebuild
+++ b/app-misc/no-more-secrets/no-more-secrets-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
@@ -10,7 +10,7 @@ if [[ ${PV} == *9999 ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/bartobri/no-more-secrets/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~arm64"
fi
DESCRIPTION="Recreate decrypting text from 1992 movie 'Sneakers'"
@@ -19,11 +19,12 @@ HOMEPAGE="https://github.com/bartobri/no-more-secrets"
LICENSE="GPL-3"
SLOT=0
+BDEPEND=""
DEPEND="sys-libs/ncurses:0="
-RDEPEND="${DEPEND}"
+RDEPEND=""
PATCHES=( "${FILESDIR}"/no-more-secrets-9999-2018-10-25-respect-ldflags.patch )
src_compile() {
- CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" emake
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" emake all
}